Pamac Update Manager causes the system to freeze

Excuse me, what now?
Did you really mean to say pacman (Arch’s package manager also usable on Manjaro) or rather pamac (Manjaro package manager, which this thread is all about).

The problem is originated in pamac (Manjaro GUI for the package manager) and I found that before deciding to to stop the auto “check for updates” also when I was using pacman commands (Arch’s pakcage manager) the process named pamac-checkupdates was triggered.

That is the reason why I added the comment since when I stopped with the updates in pamac all became normal, except I will manually check if any updates came out.

Hope it is clear now :slight_smile:

The problem still lies within pamac - one just can trigger it’s execution by using pacman.

But is there any other solution other than turning off the “check updates” ??

Did you bother to read [comment #17]?

There has been no updates to pamac-{gtk,gtk3} since the last build in mid December 2023 and libpamac since December 2. 2023 - so one can only specualte what changes the OP has made prior to posting that comment.

So if you are having these memory issues the current recipe is disable AUR.

1 Like

A simple no would have been enough and yes I did “bother” to read that is why I asked

If it helps:
Turn off auto updates, including flatpak & AUR.
Restart your box.
Run pamac and manually check for updates and if there are no updates then clear the cache on exit.
Restart your machine and turn on autoupdates. (I think I turned on flatpak & AUR after things worked first)

The problem does not persist in my desktop. That’s what seems to have happened to me.
I will mark this as my solution.

I am going to test it this evening


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.