Pamac system tray widget missing

Hello - sorry if this has been answered, I’ve looked around and couldn’t find anything.

Since the last stable update - the pamac system tray widget is missing entirely. It’s not even in the System Tray Settings dialog as an option to enable. I have tried uninstalling and reinstalling pamac-tray-icon-plasma with no effect.

Grateful for any insight!

UPDATE: after several relogs and restarts, it has oddly re-appeared on its own. I still don’t know why this happened.

Doesn’t appear “Updates” in system tray settings? :thinking:

Have you tried activating “Always show all entries”?

No. I checked. It is entirely absent. “Always show all entries” simply displays every entry present in that list. The updates one does not appear when this happens.

1 Like

I am experiencing the same issue after the update. It doesn’t even show as an entry in System Tray Settings (see below)

Same for me. I tried to reinstall pamac-tray-icon-plasma and did the relog several times, nothing helped

Reading what @maycne.sonahoz says in this post about stopping Update Manager:

Can you test if app-msm_kde_notifier@autostart.service and app-pamac\x2dtray\x2dplasma@autostart.service are both in “loaded active plugged” status? An easy way to do it:

systemctl list-units --user | grep pamac

systemctl list-units --user | grep kde_notifier

Mine is showing again. I think the latest updates have solved it, somehow…

1 Like

I created another user and it started working.