Pamac says 7.06-3 >>> 7.08-1 upgrade?

However it complains

unable to satisfy dependency 'virtualbox=7.0.8' required by virtualbox-ext-oracle

Then I tried yay, thinking I might get a different result but no.

[sudo] password for xxxx: 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Searching AUR for updates...
 -> No AUR package found for virtualbox=7.0.8
:: Searching databases for updates...
 -> Flagged Out Of Date AUR Packages: google-chrome
:: 2 Packages to upgrade/install.
1  aur/virtualbox-ext-oracle  7.0.6-3 -> 7.0.8-1
==> Packages to exclude: (eg: "1 2 3", "1-3", "^4" or repo name)
 -> Excluding packages may cause partial upgrades and break systems
==> 1
 -> could not find all required packages: virtualbox =7.0.8

Any ideas much appreciated.

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Virtualbox on the stable branch has version 7.06: virtualbox package

You have to wait until the stable branches receives the new version (or update to testing or unstable).

1 Like

Hi @Cencar44,

Those are both AUR packages, and while it is, indeed, possible to install and use AUR packages, they aren’t recommended or supported. Rather install packages from the repository.

For vitualbox:

I misread stuff, I was wrong. You can safely ignore this message.
$ pamac search virtualbox
virtualbox                                                                                                                                                                                                  [Installed] 7.0.6-3                   community
Powerful x86 virtualization for enterprise as well as home use

…which is in the community repository and can be installed using:

pamac install virtualbox

For Chrome

Google chrome is only available in the AUR:

$ pamac search google-chrome
google-chrome                                                                                                                                                                                                              [Installed] 112.0.5615.49-1  AUR
The popular and trusted web browser by Google (Stable Channel)

So the update should be installable using:

pamac build google-chrome

Hope this helps!

moved to AUR

Manjaro stable is behind Arch in regard of package versions at the moment and AUR packages are made for Arch.
You can check Manjaro package versions on its different branches yourself:

You can’t install virtualbox-ext-oracle from repositories what are you talking about?

Don’t update the Virtualbox Extension Pack AUR package until Virtualbox reaches the proper version in Manjaro.

Apologies. I see now. I misread something.

1 Like

Is indeed the problem. I have:-

Oracle VM VirtualBox (virtualbox) 7.0.6-3
Official Repositories (commmmunity) installed

But the virualbox-ext-oracle Extension Pack 7.0.6-3
is AUR. installed. I’ll just wait until Manjaro updates.
Thanks every one.

I had the same issue on the unstable branch yesterday.Today when i checked it had the latest version so I updated and now am on 7.08.

Ok people just when I thought it was over!
I got this from pacmac,(I don’t like using images because some one scolded me for excessive bandwidth). But this was way beyond my ability to decipher.

It also complained that it could not satisfy dependencies: and aborted.

The solution uninstalled Community Virtualbox 7.0.6-3 and AUR extension pak 7.0.6-3. Then reinstalled Community Virtualbox 7.0.6-3 and went to :-

Now according to Pacmac the only thing installed is Community Virtualbox 7.0.6-3 which meets the system parameters. Now Pacmac is up to date and virtualbox has shared folders and USB connection. If any one else was having problems with virtualbox I hope it helps.

So now you have both Virtualbox and its extension pack installed from the AUR. I think this is better to do as you were told, as you seem to already have issues understanding how everything works together, next time Virtualbox from AUR will require dependencies not in the Stable branch what will you do? Come back here and ask how to make it work?

For you my advice is, use Virtualbox from repositories. Do NOT check for AUR updates with Pamac, and update the extension pack when it is at the proper version, with another AUR helper like yay.

You do as you want but piling AUR packages to fix your issues will not help in the long run.

@omano It is obvious you did not read the post. I do not have any AUR packages installed.
1.Community Virtualbox 7.0.6-3
2.Virtualbox-extension-pack 7.0.6-3 from Oracle website.

Because you use yay - even though the extension pack is downloaded from Oracle

Yay is an AUR helper and therefore yay tells you there is an update to the extension pack.

If you want to avoid confusion - I recommend using either pamac (disable AUR check) or pacman.

@linux-aarhus, no I went to the Oracle website, down loaded it and manually installed it.
The community repo has Virtualbox 7.0.6-3 but no 7.0.6-3 extension pak. That’s were the issue began.
Why would community have one but not the other?
However, I do take your point about the AUR and have disabled it.

I may have misread something indeed, I thought you ended up installing it.

I don’t know what you still didn’t understand then, you didn’t have to do any of that, thread was solved, DO NOT UPDATE the extension pack from AUR when it is not the same version as Virtualbox in the repositories.

Still, what I said stands:

Also Pacmac doesn’t exist, it is Pacman, or Pamac, not Pacmac.

This is due to redistribution restrictions and licensing as the extension pack is a closed source package.

(2) You may not do any of the following: (a) modify any part of the Product, except to the extent allowed in the documentation accompanying the Product; (b) rent, lease, lend, re-distribute, or encumber the Product; (c) remove or alter any proprietary legends or notices contained in the Product; or (d) decompile, or reverse engineer the Product (except to the extent permitted by applicable law).

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.