Pamac preferences are being opened even when a software is being installed

Recently I noticed that all the options from the pamac hamburger menu can be opened while a software installation is in progress!

If I remember correctly, previously only software mode, history and about could be opened (others remained grayed out) while software were being installed or removed. Is this some new feature or a bug? Please correct me if I am wrong.

Yes, now you can open the preferences menu during a transaction but the critical options can’t be changed.


Also, I opened the preferences once by mistake. I changed nothing but when I tried to close the preferences window, I was prompted for password which I provided, but the window refused to close.

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.