Pamac PKGBUILD edit doesn't work now

I used to install AUR packages with pamac (either pamac-gtk or pamac-cli), and I was able to edit the PKGBUILD for the AUR packages with them. In my case it is zoom that I need to remove the ibus dependency to make it install on my system. This feature suddenly stops working maybe since the last update. I tried to manually edit the PKGBUILD before upgrading zoom today to remove ibus as a dependency. However, after editing, it kept asking me if I agree to install ibus as a dependency. This behaviour happened on both pamac-gtk and pamac-cli, so I think it may be a libpamac problem.
Eventually I just downloaded the PKGBUILD, edited it, and then use makepkg to create the zst and use pacman -U to install it. I hope the devs can investigate if this is a pamac’s issue.
Here’s my system information:

  Kernel: 5.10.63-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: initrd=\amd-ucode.img initrd=\intel-ucode.img 
  initrd=\initramfs-5.10-x86_64.img zfs=zroot/manjaro/root rw 
  Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop System: Micro-Star product: MS-7C37 v: 3.0 serial: <filter> 
  Mobo: Micro-Star model: X570-A PRO (MS-7C37) v: 3.0 serial: <filter> 
  UEFI: American Megatrends LLC. v: H.D4 date: 04/09/2021 
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard serial: <filter> 
  charge: 55% (should be ignored) rechargeable: yes status: Discharging 
  Device-2: hidpp_battery_1 model: Logitech Wireless Mouse serial: <filter> 
  charge: 55% (should be ignored) rechargeable: yes status: Discharging 
  Info: 8-Core model: AMD Ryzen 7 5800X bits: 64 type: MT MCP arch: Zen 3 
  family: 19 (25) model-id: 21 (33) stepping: 0 microcode: A201009 cache: 
  L2: 4 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 121658 
  Speed: 3624 MHz min/max: 2200/3800 MHz boost: enabled Core speeds (MHz): 
  1: 3624 2: 3372 3: 2882 4: 3601 5: 2886 6: 2887 7: 3870 8: 3870 9: 3210 
  10: 3607 11: 2884 12: 2891 13: 2886 14: 2901 15: 3457 16: 2904 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: always-on, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA TU104 [GeForce RTX 2080] vendor: Gigabyte driver: nvidia 
  v: 470.63.01 alternate: nouveau,nvidia_drm bus-ID: 2d:00.0 
  chip-ID: 10de:1e82 class-ID: 0300 
  Device-2: Logitech Webcam C930e type: USB driver: snd-usb-audio,uvcvideo 
  bus-ID: 1-2:3 chip-ID: 046d:0843 class-ID: 0102 serial: <filter> 
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
  loaded: nvidia display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x2160 s-dpi: 159 s-size: 613x352mm (24.1x13.9") 
  s-diag: 707mm (27.8") 
  Monitor-1: DP-0 res: 3840x2160 hz: 60 dpi: 161 size: 607x345mm (23.9x13.6") 
  diag: 698mm (27.5") 
  OpenGL: renderer: NVIDIA GeForce RTX 2080/PCIe/SSE2 
  v: 4.6.0 NVIDIA 470.63.01 direct render: Yes 
  Device-1: NVIDIA TU104 HD Audio vendor: Gigabyte driver: snd_hda_intel 
  v: kernel bus-ID: 2d:00.1 chip-ID: 10de:10f8 class-ID: 0403 
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI X570-A PRO 
  driver: snd_hda_intel v: kernel bus-ID: 2f:00.4 chip-ID: 1022:1487 
  class-ID: 0403 
  Device-3: Logitech Webcam C930e type: USB driver: snd-usb-audio,uvcvideo 
  bus-ID: 1-2:3 chip-ID: 046d:0843 class-ID: 0102 serial: <filter> 
  Sound Server-1: ALSA v: k5.10.63-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.35 running: yes 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Micro-Star MSI X570-A PRO driver: r8169 v: kernel port: d000 
  bus-ID: 27:00.0 chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp39s0 state: down mac: <filter> 
  Device-2: Edimax Edimax AC1750 USB type: USB driver: 8814au bus-ID: 1-1:2 
  chip-ID: 7392:a833 class-ID: 0000 serial: <filter> 
  IF: wlp42s0f1u1 state: up mac: <filter> 
  Supported mdraid levels: raid1 
  Device-1: md127 maj-min: 9:127 type: mdraid level: mirror status: active 
  size: 513.9 MiB 
  Info: report: 2/2 UU blocks: 526272 chunk-size: N/A super-blocks: 1.0 
  Components: Online: 
  0: nvme0n1p1 maj-min: 259:2 size: 514 MiB 
  1: nvme1n1p1 maj-min: 259:5 size: 514 MiB 
  Device-2: zbigdata type: zfs status: ONLINE level: linear raw: 
  size: 1.81 TiB free: 1.08 TiB allocated: 750 GiB zfs-fs: size: 1.76 TiB 
  free: 1.02 TiB 
  Components: Online: 
  1: sdb maj-min: 8:16 size: 1.82 TiB 
  Device-3: zhome type: zfs status: ONLINE level: linear raw: size: 464 GiB 
  free: 316 GiB allocated: 148 GiB zfs-fs: size: 449.62 GiB free: 301.25 GiB 
  Components: Online: 
  1: sda maj-min: 8:0 size: 465.76 GiB 
  Device-4: zroot type: zfs status: ONLINE level: mirror raw: size: 920 GiB 
  free: 625 GiB allocated: 295 GiB zfs-fs: size: 891.5 GiB free: 596.03 GiB 
  Components: Online: 
  1: nvme0n1p3 maj-min: 259:4 size: 921.01 GiB 
  2: nvme1n1p3 maj-min: 259:7 size: 921.01 GiB 
  Local Storage: total: raw: 4.09 TiB usable: 5.35 TiB used: 1.12 TiB (20.9%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Corsair model: Force MP600 
  size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s 
  lanes: 4 type: SSD serial: <filter> rev: EGFM13.0 temp: 36.9 C scheme: GPT 
  ID-2: /dev/nvme1n1 maj-min: 259:1 vendor: Corsair model: Force MP600 
  size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s 
  lanes: 4 type: SSD serial: <filter> rev: EGFM13.0 temp: 33.9 C scheme: GPT 
  ID-3: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 500GB 
  size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: 1B6Q scheme: GPT 
  ID-4: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST2000DX002-2DV164 
  size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: HDD rpm: 7200 serial: <filter> rev: CC41 scheme: GPT 
  ID-1: / raw-size: N/A size: 859.92 GiB used: 263.89 GiB (30.7%) fs: zfs 
  logical: zroot/manjaro/root 
  ID-2: /boot raw-size: 512.9 MiB size: 511.9 MiB (99.80%) 
  used: 122.8 MiB (24.0%) fs: vfat dev: /dev/md127p1 maj-min: 259:8 
  ID-3: /home raw-size: N/A size: 432.37 GiB used: 131.12 GiB (30.3%) fs: zfs 
  logical: zhome/manjaro/home 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 10 GiB used: 16.7 MiB (0.2%) priority: -2 
  dev: /dev/nvme0n1p2 maj-min: 259:3 
  ID-2: swap-2 type: partition size: 10 GiB used: 16.8 MiB (0.2%) priority: -3 
  dev: /dev/nvme1n1p2 maj-min: 259:6 
  System Temperatures: cpu: 48.4 C mobo: 34.0 C gpu: nvidia temp: 48 C 
  Fan Speeds (RPM): fan-1: 1254 fan-2: 2360 fan-3: 825 fan-4: 591 fan-5: 0 
  fan-6: 0 fan-7: 1373 gpu: nvidia fan: 0% 
  Processes: 561 Uptime: 13h 34m wakeups: 121 Memory: 15.61 GiB 
  used: 11.82 GiB (75.7%) Init: systemd v: 249 tool: systemctl Compilers: 
  gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1624 lib: 376 Shell: Bash 
  v: 5.1.8 running-in: yakuake inxi: 3.3.06

@Aragorn , do you mind explaining why was this thread categorised as AUR? I believe it’s not an AUR issue but pamac’s, which is the core package of Manjaro.

Your problem is with the editing/modifying of PKGBUILD files, which is an AUR thing.

Pamac has AUR support, but unless the defaults were recently changed, this support is not enabled by default, and Pamac’s primary function is to install and manage packages from the Manjaro repositories. :slight_smile:

I’m following this because, if I understood correctly, the op found that the ‘edit’ function in pamac ‘suddenly stops working’.

Even if I don’t completely get how it stops working, if pamac can’t edit build files I’ll have a problem when my next nvidia-340xx-dkms update is due and I recon I won’t be the only one.

UPDATE: Just updated the driver and pamac’s ‘Edit Build Files’ worked

@dobedobedo please open an issue if not there already: Issues · Applications / pamac · GitLab

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.