Pamac pending button does not show the pending transactions

Actions leading to issue:

  • Open Pamac GUI
  • Select a package to install
  • Press the pending button on the left

Expected outcome:

  • Pamac should show pending transactions


  • Nothing happens

Solutions I have tried:

  • I tried reinstalling Pamac but I run into a lot of problems in terms of my disto(Manjaro) and dependencies
  • Tried on other computer(Both ASUS)
  • I have tried looking for solutions but could not find any online
  • For some reason switching to software mode will show the pending transaction

System info:

  • ASUS Vivobook Go 15 E1504FA
    • Kernel: 6.6.25-1
    • Distro: Manjaro Gnome X11
  • ASUS Vivobook 15 X540UAR
    • Kernel: 6.6.19-1
    • Distro: Manjaro Gnome X11

Side notes:
I always used to prepare packages for installation, then check my pending packages, and then applied it.
I don’t like the software mode so having to constantly switch between the two to see pending packages is annoying.
Please let me know if there is anything I should add as well as if you experience the same problem as I have not been able to find any reference to it online.

Please create an upstream issue if there isn’t already an existing one:

I actually tried that first but I have to sign in and cannot for the life of me find out where to register. I have a gitlab account that I tried to sign in with but to no avail.

You did see the red banner at the top, right?

Cannot reproduce on pamac-gtk (the gtk4 version, on stable branch). Are you using pamac-gtk3?

@Yochanan Sorry, I thought that is when you already registered and the process takes long or something. I sent the request now.

@Teo I am on GTK4. That is what is strange to me. I don’t seem to find anyone else having the same problem. Though the fact that it happens on both my laptops made me want to sort it out.

As a side note, I have AUR, flatpak and snap enabled but disabling them does not change anything.

Pamac in general seems a bit more buggy than it used to for me(I used to love it, I still do but the experience does not have such a “premium” feel as it used to) as it used to include updates in the transaction info on the bottom and a bunch of similar things. Maybe the problems are related?

Same problem on my PC : xfce and pamac-gtk 11.7.1-1
I select several packages to install, then click on"pending" : nothing happens, no change in the display, I can still select other packages.

The blue button is actually Apply and not pending.

“En attente” = pending

I just noticed the pending category in the left pane…for 1 year using manjaro never knew it was there. Indeed, if i click on it, it does nothing.

So I am still waiting on my confirmation email from the Manjaro gitlab so that I can open an issue. I have gone to the support page to request email verification but have not yet received an email. I tried once or twice after waiting for a while. Is there something I am missing?

@Teo Yeah the issue literally started about a year ago. You can still reach it by going to the 3 dots and selecting software mode.
It actually comes in handy as I sometimes have multiple packages I want to install and to make sure there are no duplicates or if I find a better alternative to something and quickly want to cancel the initial package.

Looks like it is a pamac-gtk issue, as it is working fine on pamac-gtk3:

1 Like

I am using pamac-gtk3 10.6.0-4 on Xfce

[Testing update] 2023-06-24 - Known issues and Solutions

Pamac GUI theme does not match theme for Xfce

pamac-gtk 11.0.1 uses Gtk 4 that is not supported by Xfce
user can replace pamac-gtk with pamac-gtk3

sudo pacman -S pamac-gtk3

pamac-gtk3 is working as expected to show Pending packages from Manjaro repositories. But it does not work reliably if AUR packages are selected - GUI can sometimes crash if AUR database is not up to date. So I prefer pamac CLI for installing/updating AUR packages most of the time

I created an issue

@Teo Thx. Can I mark that as the solution? This is my first time on the forum so I don’t know if that constitutes a solution.

I guess filing a bug report on gitlab is a solution in the forum, yeah :slight_smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.