Pamac: password prompt fails after indefinite amount of time

when installing packages, particularly building them from AUR, pamac hangs on a password prompt right at the end of the installation process. Sometimes if the password prompt isn’t filled within some period of time, the installation will fail. Some of my builds and installations take a long time and when I come back to them and place in confirmation on said prompt, the installation fails. Until I figured out that built binaries are stored, this was even more of a problem because I would need to build the package again.

Even if the installation didn’t fail, It will also be convenient for the prompt to not come at the end. It is a hassle having to remember to focus the terminal to check after an indefinite amount time has passed.

would it be possible to make pamac ask for password at the beginning of the installation process along side confirmations instead?

–no-flag doesn’t help because it can’t be used for AUR packages.


As far as I know, the reason pamac waits intil the end, is because that’s actually the correct place to ask for the password: When the package is about to get installed.

As far as I know, most AUR helpers do this, so the build process is not run with sudo rights.

Yes but in this case, you put your sudo password from the start and it timesout really quickly by default.

Some of use have older hardware and our stable many times over GiB updates takes longer than five minutes.

To remedy this you can add different sudo timeout period in file

Add somewhere a line

Defaults timestamp_timeout=0

To disable timeouts completely or some values in minutes.

Pamac uses Polkit for authentication. Pamac asks for your password before starting the build process but if it’s too long (the time delay is defined by Polkit), the password can be asked again when installing packages.
I know this behavior can be annoying but it’s for security reasons.

1 Like

Is it possible to extend the time delay? I assume Polkit gives sudo access only to pamac and I am fine with that.

I saw @freed00m 's post. I will use that.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.