Pamac not working properly: fails to remove packages, doesn't show updates

For months now Pamac has been malfunctioning. When I try to remove a package, I get an error ‘target not found: packagename.’ When I try to update, it will search for updates but tell me that everything is up to date. For awhile, I thought Manjaro was just having a long time in between updates when in reality Pamac just wasn’t displaying updates properly.

Here is a video recording of the misbehavior I am experiencing. I had to restart in the process which is why there’s 2 videos. The 2nd video is just confirming that the problem is not fixed.

Is the problem also there with other packages except redshift? Also, is the problem also with updates with pacman?
Honestly, you shouldn’t have to make videos about these. But even after you did, I was in a lack of information. See this :–


The problem exists with any package I try to uninstall via pamac, I just used redshift as an example because it’s small and in the main repository. If the problem was just with redshift, I would have said it was only a problem with redshift.

The problem with updating is that pamac will tell me there are no updates when in reality there are. In order to get these updates, I need to install a package I do not already have installed to trigger the proper update process. I don’t know if this even works properly, as re-installing redshift triggered a bunch of other package updates, which it triggers everytime. However the package list is significantly smaller than it had been in the past when I believe pamac is actually doing an update.

1 Like

You can update via sudo pacman -Syyu

EDIT: With regard to the issue with pamac, have you tried refreshing the database?
pamac update --force-refresh

EDIT2: Could also be a mirror issue, try:
sudo pacman-mirrors --continent && sudo pacman -Syyu

1 Like

I did pamac update --force-refresh and tried removing and installing redshift and everything worked properly.

I will wait awhile and see if Pamac also pulls updates properly before trying the last command.

Thank you for the response.

1 Like

I was having exactly the same issues as the OP and just wanted to open a new thread for this, but your solution worked for me too.
I don’t really know what went wrong, but thank you :relaxed:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.