Pamac not showing updates


For quite some time now I have an issue with Pamac (GUI). It doesn’t show any updates. However, when I look into cockpit I can see that currently there is update for sudo, firefox etc. I can see the same updates also via command line using pacman -Syu.

Could you please help me to understand what went wrong and how to fix Pamac GUI to properly show updates?


Try from terminal:
sudo pacman-mirrors -f5 && sudo pacman -Syyu
Reboot after that.

1 Like

I tried to refresh mirrors and also run the 2nd command. The issue is that I don’t want to run updates via terminal (where it works) all the time. It should work also from pamanc, or not?

It really seems like pamac is not able to process something from mirrors.

:wave: welcome :slight_smile:
Do you use ?

It might be a good idea to post some more info about your system and your problem.
What does $ pamac --version output for instance.
What is quite some time?

Same for me, no updates indicated. Pamac 10.0.4-2

1 Like

sudo pacman-mirrors -f5 && sudo pacman -Syyu does a update of your mirrors and makes sure you update correctly. After the reboot it should be as normal.

Executed, rebooted, system updated. Unfortunately since system updated from terminal I won’t be able to test if pamac works unless there are new updates. This is why I wanted to avoid updating from terminal as then I can’t see if there are any updates showing in pamac.

  1. cockpit - I installed it in the past using pamac (from official repositories). So I guess its the one you linked.
  2. pamac version - Pamac 10.0.4-2
  3. Regarding time. Manjaro is not my primary system. I would say its roughly 3 weeks now.

I have the same version of Pamac as pepco, and no updates showed by the GUI. Icons in the former versions (or in 2020, impossible to know) become red in case of updates, no it is always white for me.

This thread has some more things to check. If the problem persists more data is needed, the output of the sudo pacman-mirrors -f5 && sudo pacman -Syyu would be a good start.

I have removed ~/.config/pamac then used “sudo pacman-mirrors -f5 && sudo pacman -Syyu”, now it works for me. THANK YOU.

1 Like