Pamac not following dark theme KDE

Hello guys I have been facing this issue since the first installation day pamac doesn’t follow dark theme and has some weird light theme


Here are my theme settings
Global Theme: Breath2
Plasma Style: Breath2 Dark
Application Style: Breeze
Colors: Breath2Dark

1 Like
4 Likes

Thank you a lot

After fixing colors problem toolbar icons are too big and ugly changed window decorations System Settings > Application Style > Window Decorations > Theme it got smaller but after restart still like this:

Same issue here. Changing the GTK theme (in this case, I’m using breeze-gtk) during a session yields the correct titlebar button size (minimize, maximize, close).

However, logging off and logging back in results in huge buttons. Note that the button icons are actually wrong as well (e.g., the x should be inside a circle).

Update: I was able to resolve this problem (i.e., the icons maintaining correct size after logout) by installing the breeze-gtk theme through the official repos and NOT the “Get New GNOME/GTK Application Styles” button.

1 Like

An other problem occurs when using the breeze-gtk from official repos. I use “breeze-dark” as my theme on KDE but the dark variant only works in gtk3 application. In fact, on gtk2 programs, breeze [light] is applied instead creating inconsistency. I’ve already installed kde-gtk-config but nothing changes. On the drop-down menu, when deciding the gtk theme in System Settings > Application Style > Configure GNOME/GTK Application Style, there’s no “breeze-dark” listed, only “breeze” (I don’t know if this is normal or not).
Thanks in advance.

With this new version of plasma, the application colors for gtk apps should follow whatever you have set in the “Colors” menu, hence you only need “breeze” instead of “breeze dark” (this is consistent with how the regular plasma application styles operate too). After you’ve set the gtk app style to breeze, try opening up a gtk application (breeze-gtk is supposed to apply to both gtk2 and gtk3) and switching around colors to see what happens.

I’ve done some testing and the colors are applied only on QT and GTK3 programs, not in GTK2 applications. I’ve also tried with different GTK themes other than breeze and the problem persist. In addition to that I see that there is a dark variant version for every GTK theme (so there is adwaita and then adwaita-dark, breath and breath-dark and so on). So maybe it isn’t supposed to change colors for GTK2 programs in the first place (?)

Ah, I see. Weird, the package description for breeze-gtk says it works for both gtk2 and gtk3. Would you mind sharing a gtk2 app you are using so I can test along with you?

Sure. Gpick and gimp are both gtk2 apps that I use. In gimp you must set the “default” theme so that it follows the system theme: Edit > Preferences > Interface > Theme.

Ok, same results here. I tested both Gpick and GIMP and they completely ignore Color settings, while GNOME/gtk3 apps like Pamac and Peek follow them accordingly.

It looks like KDE is just future-proofing Plasma as gtk2 goes the way of the dodo.

All is well though, since it looks like the upcoming 3.0 version of GIMP uses gtk3. :slight_smile:

It looks like the breeze-gtk package description needs to be updated though if it no longer applies to gtk2 apps (at least, the way we’d expect in the latest Plasma).

1 Like