Pamac-manager won't ask for sudo password and fails to install AUR packages

Hi all,
I have a problem with pamac-manager (GUI one).

It won’t ask for root password and then fail to install AUR package. Normal repo packages or going to preferences will trigger sudo window and it works OK. But installing AUR will not ask for it and fail. When I open it from terminal via sudo pamac-manager, it will work fine. But without sudo, I can do things, certain operations will ask for sudo password and will get it, but installing or removing AUR package will not trigger it.
It worked fine last week but I just noticed that now it won’t.
Anyone experienced something like this?
How can I reset or reinstall pamac-manager, is it advisable?

I am using latest Manjaro with KDE, kernel 5.10, all fully updated.

Kernel: 5.10.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.10-x86_64
root=UUID=e20841c6-737f-4222-af41-4fb2bf054f50 rw rootflags=subvol=@ quiet
apparmor=1 security=apparmor udev.log_priority=3
Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM
Distro: Manjaro Linux

When I run pamac-manager from terminal that’s what I see when attempted to install some random AUR “asap2”:

$ pamac-manager

(process:235411): GLib-GIO-WARNING **: 17:05:37.397: /etc/xdg/kde-mimeapps.list contains a [Added Associations] group, but it is not permitted here. Only the non-desktop-specific mimeapps.list file may add or remove associations.

(pamac-manager:235411): Gtk-WARNING **: 17:05:37.408: Theme parsing error: gtk.css:2:33: Failed to import: Error opening file /home/pioruns/.config/gtk-3.0/window_decorations.css: No such file or directory
fatal: could not create work tree dir ‘asap2’: Permission denied

Where is that work tree of pamac located?

I think this happened when I created separate Btrfs subvolume for /var. I copied all files from old /var to new /var and adjusted fstab. Somehow, certain folder permissions were lost or set incorrectly?


This folder /var/cache/pamac is blinking red and cannot be even entered:

$ cd /var/cache/private/
bash: cd: /var/cache/private/: Permission denied
$ cd /var/cache/pamac
bash: cd: /var/cache/pamac: Permission denied

Looks like root can still enter it and work there (hence sudo pamac-manager works), but if pamac-manager is run without sudo it fails on AUR packages, as it assumes access to folders.

Anyone have idea how to fix it?
Thank you.

I’m experiencing this same issue. Hopefully someone can help find a solution?

Ok, I managed to resolve this issue. For some reason, the owner user/group got modified to 1000:1000 instead of obelisk79:obelisk79.

“Pamac build packages are stored usually in /var/tmp/pamac-build-yourusername/ You have to be the owner of that folder.”

So issuing sudo chown obelisk79:obelisk79 /var/tmp/pamac-build-obelisk79/ in terminal resolved the problem.


Yes, it worked! I knew something got broken in /var when I moved it from main SSD to HDD, but I didn’t knew what!
This solves it. Thank you :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.