Pamac Manager stopped working

Hey there!
Yesterday I have installed a couple of update packages through the pamac-manager. Unfortunately, the manager does not start anymore. The window opens for like 100ms and then directly closed. When I tried to open it through the terminal, I found the following error:

(pamac-manager:4564): Gdk-CRITICAL **: 10:03:06.217: gdk_window_set_cursor: assertion 'GDK_IS_WINDOW (window)' failed

(pamac-manager:4564): Gdk-CRITICAL **: 10:03:06.217: gdk_window_set_cursor: assertion 'GDK_IS_WINDOW (window)' failed
zsh: segmentation fault (core dumped)  pamac-manager --updates

It would be nice if anyone could help me :slight_smile:

Have you tried to open via terminal as sudo?

Have you tried logging out and logging back in, or better yet, rebooting?

Don’t ever do that. Pamac was designed to be run as a regular user. It is polkit-aware and will ask for a password when needed.

I know. It is just to see if it starts.
Had the same yesterday. Re-applied the “light” stock theme and after a reboot switched back to dark theme and pamac manager opened again normally.

btw. I also still get the same error in terminal:

(pamac-manager:5408): Gdk-CRITICAL **: 10:31:05.223: gdk_window_set_cursor: assertion ‘GDK_IS_WINDOW (window)’ failed

1 Like

A “couple of update packages”, as in, instead of a full system update?

I meant all available update packages :slight_smile:

I have tried it with sudo, and it did work; but as you have said, this is not a solution

Have you rebooted since then?

This error also comes, when I start it with sudo (where it does work), so it can not really be the purpose. I think the main error is zsh: segmentation fault (core dumped) pamac-manager --updates

Yeah, it did not work. I think one package from kde or manjaro is a little bugged. Or another guess: The kernel has an error → I am using the newest version 5.l5.7-1

sudo pacman-mirrors -f && sudo pacman -Syyu

Post any errors… or if there were updates … or if ‘nothing to do’.

Ah thank you :slight_smile: After running the command and restarting, it did work again. It did said something like updated config /var/lib/mhwd/local/pci/video-nvidia this could have been the problem.

do you still get the error message in terminal with pamac-manager?
In my case I still have the error message. pamac works fine though trough GUI

pamac-manager is a GUI application …
The errors about set_cursor are more or less cosmetic and probably afflicts everyone … one sec … yup I have it too, next to a kio-mimeapps one.
IDK … I dont use pamac. :woman_shrugging:

PS - pamac is the cli version … such as pamac update

well, I wasn’t bothered by the error message anyway. GUI works and system updates I usually apply via terminal. Just in this support case when pamac does not start an error message usually indicates something is not right.
anyways, Simax’s problem is solved, luckily. thanks.

But I also meant it was not the error message … this was:

But, on a hunch, I assumed we didnt need to go getting the coredump and instead guessed that it was a partial-upgrade/mirror/etc situation.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.