Pamac-manager: flatpak search doesn't work

Hello everyone! I tried to google it but no luck, and there is no similar topic on this forum either. The problem as follows: even though I have all the dependencies installed, libpamac-flatpak-plugin search doesn’t work. Apparently it should search on flathub.org by default but it doesn’t. The native flatpak search works fine. I looked up in pamac.config and flatpak repo config but didn’t find any references.
I attached some pics so you could grasp easier.



Hello,

I could reproduce your issue on a fresh install, so i refreshed the database from UI

image

Closed Pamac Ui, then i open it from terminal with
pamac-manager
then the search worked

All other searches from Flatpack worked after that, but i can’t quite pinpoint the real initial issue …

Thank you for your attention to the problem. I repeated your steps but that didn’t help — the search still doesn’t work. I even tried to disable plugin, refresh db, then turn it back and refresh db once again. Still no luck.

I had a similar problem. I solved it by:

  1. From the command line “flatpak search vlc”

After results came back gui searches worked as expected.

I have no idea why but it worked. Thanks!