Pamac-Manager Authentication Failure

The other day, pamac-manager started to fail in building or installing any package. It would say “authentication failure.” Any ideas for what to do with this problem?

Usually is due to issue to Polkit - ArchWiki
Since you tagged XFCE and awesome-wm, make sure you have this enabled at startup

image

and polkit-gnome is installed. If the issue is only on awesome-wm, then check your startup scripts …

where would I enable that?

If you are on XFCE then in Settings > Session and Startup > Application Autostart

1 Like

I usually use Awesome-WM daily, how could I change it there?

In your autostart.lua you should have an entry something like this:

os.execute("/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 &")
1 Like

where is that autostart.lua file? I couldn’t find it in ~/.config/awesome/

It depends how you installed awesome … and how you customize it … might be rc.lua

Would this count as a command to run in the terminal? I have a place to write the commands that I want to be run on startup

Ok then, that command should be there. :slight_smile: