Pamac issue “error: GPGME error: No data"

I had an issue, while running updates from the pamac GUI. The following error:

invalid or corrupted package (PGP signature)

was thrown by the GUI, with an option to edit some files afterwards.
In the console, the error persisted and even on pacman, I got:

error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
[…]
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: failed to synchronize all databases (invalid or corrupted database (PGP signature))

I then discovered, that the problem could be fixed temporarily by deleting the sync files of pacman via
sudo rm -R /var/lib/pacman/sync and adding the required keys via sudo pacman -Syy

However, after running pamac update again, the error returned.

In the end I looked up the files, that pamac added into the /var/lib/pacman/sync folder and discovered, that the *.sys files all had the same size and were no signatures, but valid HTML of a website I previously used to sign into a WLAN on a train.

To fix the error I ran the same steps as before:

sudo rm -R /var/lib/pacman/sync
sudo pacman -Syy

and deleted the temporary files of pamac via

sudo rm -rf /tmp/pamac

which seems to have done the trick.

If anyone knows, why pamac copied this website into the *.sig files, let me know or make a report on gitlab pamac issues to get rid of this error, I feel like I used the shotgun to solve this problem and can’t reproduce it :stuck_out_tongue:, so my issue report would probably not help very much. Hope this helps future people with flying cars and the same problem.

Hi @Salatan, and welcome!

Please see

1 Like

Thank you very much, that was the theory I was missing behind the solution :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.