Pamac is broken

Hi @zuluugugulumugu, and welcome!

Seeing as my, and I expect many people here’s crystal ball is malfunctioning, we need more information from you. More specifically error messages. So please provide the error message exactly as it’s shown to you. And seeing as you’re new here:

In order for us, or anyone for that matter, to be able to provide assistance, more information is necessary. To that end, please see:

Please also note and heed: Forum Rules - Manjaro

Hope you manage!

:bangbang: Tip: :bangbang:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby improving legibility and making it much easier for those trying to be of assistance.

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

Please edit your post accordingly.


I see, so i already provided you with the error messages. Please tell me what you need exactly.

What does the crystal ball mean? Is it amateurish behavior or sth?

i did this command, nothing really changed

Please don’t use made-up abbreviations. See:

This: :point_down:

Is not an error message.

1 Like

It means your topic is assuming we can read your mind - which we cannot - and we don’t understand what you are saying.

Please elaborate - and don’t even think of using images.

Please see

1 Like

Oh right, i thought you can. Sorry.

Well, that’s why we need the error messages as described previously.


So the exact error message is:

Process could not be prepared successfully
invalid or corrupted database.

Its not in the terminal.

1 Like

Sorry, i understand you guys now.

1 Like

Meanwhile, im trying to find the thread i tried the commands from or is there something better i can help you with?

Its by the way only the flatpak, aur and snap packages i install manually that arent working right now.

Search results for 'invalid or corrupted database' - Manjaro Linux Forum.

Selfcontained apps in snap and flatpak format is only supported by whoever created it.

Custom packages from AUR should only be used with Manjaro unstable branch

Please provide the output to the following:

pamac checkupdates --force-refresh

And please, run it from a terminal so you can copy-and-paste the output.


found the thread, this is what i did

i did it because the thing with the updates was there before so when i tried to update manually i didnt work and i got the error message i mentioned before. It worked for a few days, but now like i said i cant install things.

The best way to get your system corrupted is by installing packages without updating your system first.

What is the output of… :point_down:

inxi -Fazy


Please see reread these commants #15 and #8


Its long, im sorry, but can you tell me what output you need exactly.

I think this thread goes really wrong here. We should go back to basics and understand what the problem here is. Pamac is a graphical program, but also can be used as a terminal program to update your system and also install additional software thru flatpak and snaps plus the AUR.

The best thing is to turn all those 3rd party options in settings off and try to do a system update. @zuluugugulumugu you can simply open a terminal window and issue pamac update and post the result. Also checking your /var/log/pacman.log file will give you a clue which updates were done on the OS side of things. Snaps and Flatpaks are separate systems of how you can install software. The AUR may interfere with regular OS updates.

Posting the output of inxi -Fazy will give a general idea of your system.

Article to read:


#8 is exactly the things i did, that were proposed in the thread i sent you, isnt it?

All of it. See @Mirdarthos’ post above for how to insert the output in your post.