Pamac (GUI) is not showing updates but Discover is

I was not sure if this was the correct place to post my question. Apologies if it is not…
I am running Manjaro stable.

I have been noticing that in the past couple of days Discover was indicating that there where updates to the system. Usually, Pamac tells me when updates happen, and usually at the same time as Discover, but not in the last couple of days. Today, I noticed that when I opened Pamac for the first time today, it was showing me that the system was updated and I knew that that was not the case because Discover was telling me updates were pending (about 1.3 Gigs).

I then opened Pamac today for the second time and refreshed my mirrors list. Instead of showing me the system is updated message, it finally was showing all the packages that needed to be updated. Are the mirrors today slow? I am in the southern part of the USA.

I checked if my mirrors list was ok with

pacman-mirrors --status

and all the mirrors were listed as ok.

I don’t want to update just yet if the mirrors might be slow. I did notice it took longer to open the Pamac GUI a couple of times. I am thinking it might be a good time to wait a couple of days to upgrade just in case.

Here is my system info:

parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
root=UUID=920f72cd-bba8-4638-bd56-2c95fa695fdc rw quiet apparmor=1 
security=apparmor resume=UUID=29279fc2-08a7-4ece-a1ee-c14a14c56eda 
Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
Distro: Manjaro Linux 
Type: Laptop System: TOSHIBA product: Satellite A505 v: PSAT0U-01F001 
serial: <filter> 
Mobo: TOSHIBA model: Portable PC serial: <filter> BIOS: INSYDE v: 1.80 
date: 05/25/2010 
ID-1: BAT0 charge: 89.7 Wh condition: 89.7/97.2 Wh (92%) volts: 10.8/10.8 
model: PA3727U-1BRS type: Li-ion serial: <filter> status: Full 
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse PID:0080 
serial: N/A charge: 55% (should be ignored) rechargeable: yes 
status: Discharging 
RAM: total: 3.71 GiB used: 2.3 GiB (61.9%) 
RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
Info: Dual Core model: Intel Core2 Duo T6600 bits: 64 type: MCP arch: Penryn 
family: 6 model-id: 17 (23) stepping: A (10) microcode: A0B L2 cache: 2 MiB 
bogomips: 8783 
Speed: 1197 MHz min/max: 1200/2200 MHz Core speeds (MHz): 1: 1197 2: 1197 
Flags: acpi aperfmperf apic arch_perfmon bts clflush cmov constant_tsc cpuid 
cx16 cx8 de ds_cpl dtes64 dtherm dts est fpu fxsr ht lahf_lm lm mca mce mmx 
monitor msr mtrr nopl nx pae pat pbe pdcm pebs pge pni pse pse36 pti 
rep_good sep sse sse2 sse4_1 ssse3 syscall tm tm2 tsc vme xsave xtpr 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
Type: l1tf mitigation: PTE Inversion 
Type: mds 
status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled 
Type: meltdown mitigation: PTI 
Type: spec_store_bypass status: Vulnerable 
Type: spectre_v1 
mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 
mitigation: Full generic retpoline, STIBP: disabled, RSB filling 
Type: srbds status: Not affected 
Type: tsx_async_abort status: Not affected 
Device-1: Intel Mobile 4 Series Integrated Graphics vendor: Toshiba 
driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:2a42 
Device-2: Chicony USB2.0 UVC WebCam type: USB driver: uvcvideo bus ID: 1-2:2 
chip ID: 04f2:b128 
Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
loaded: modesetting alternate: fbdev,intel,vesa display ID: :0 screens: 1 
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
s-diag: 414mm (16.3") 
Monitor-1: LVDS-1 res: 1366x768 hz: 60 dpi: 98 size: 353x198mm (13.9x7.8") 
diag: 405mm (15.9") 
OpenGL: renderer: Mesa DRI Mobile Intel GM45 Express (CTG) 
v: 2.1 Mesa 20.3.3 direct render: Yes 
Device-1: Intel 82801I HD Audio vendor: Toshiba driver: snd_hda_intel 
v: kernel bus ID: 00:1b.0 chip ID: 8086:293e 
Sound Server: ALSA v: k5.10.7-3-MANJARO 
Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Toshiba 
driver: r8169 v: kernel port: 5000 bus ID: 02:00.0 chip ID: 10ec:8136 
IF: enp2s0 state: down mac: <filter> 
Device-2: Realtek RTL8191SEvB Wireless LAN driver: rtl8192se v: kernel 
port: 3000 bus ID: 03:00.0 chip ID: 10ec:8172 
IF: wlp3s0 state: up mac: <filter> 
IP v4: <filter> type: dynamic noprefixroute scope: global 
broadcast: <filter> 
IP v6: <filter> type: dynamic noprefixroute scope: global 
IP v6: <filter> type: dynamic noprefixroute scope: global 
IP v6: <filter> type: noprefixroute scope: link 
WAN IP: <filter> 
Message: No RAID data was found. 
Local Storage: total: 1.27 TiB used: 71.45 GiB (5.5%) 
SMART Message: Unable to run smartctl. Root privileges required. 
ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MK4055GSX 
size: 372.61 GiB block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
serial: <filter> rev: 1M 
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000NM0033-9ZM173 
size: 931.51 GiB block size: physical: 512 B logical: 512 B speed: 1.5 Gb/s 
serial: <filter> rev: SN04 
Optical-1: /dev/sr0 vendor: TSSTcorp model: CDDVDW TS-L633Y rev: TF01 
dev-links: cdrom 
Features: speed: 24 multisession: yes audio: yes dvd: yes 
rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
ID-1: / raw size: 926.2 GiB size: 910.67 GiB (98.32%) used: 71.45 GiB (7.8%) 
fs: ext4 dev: /dev/sdb1 maj-min: 8:17 label: N/A 
uuid: 920f72cd-bba8-4638-bd56-2c95fa695fdc 
Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
ID-1: swap-1 type: partition size: 5.31 GiB used: 1.9 MiB (0.0%) 
priority: -2 dev: /dev/sdb2 maj-min: 8:18 label: N/A 
uuid: 29279fc2-08a7-4ece-a1ee-c14a14c56eda 
ID-1: /dev/sda1 maj-min: 8:1 size: 1.46 GiB fs: ntfs label: System 
uuid: 9E4234CD4234ABC1 
ID-2: /dev/sda2 maj-min: 8:2 size: 360.47 GiB fs: ntfs label: TI102782W0E 
uuid: F2F05B87F05B50C9 
ID-3: /dev/sda3 maj-min: 8:3 size: 10.68 GiB fs: ntfs label: HDDRECOVERY 
uuid: 3E3282B932827625 
Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
speed: 480 Mb/s chip ID: 1d6b:0002 
Device-1: 1-2:2 info: Chicony USB2.0 UVC WebCam type: Video driver: uvcvideo 
interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 04f2:b128 
Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 2.0 
speed: 480 Mb/s chip ID: 1d6b:0002 
Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 speed: 12 Mb/s 
chip ID: 1d6b:0001 
Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 speed: 12 Mb/s 
chip ID: 1d6b:0001 
Hub-5: 5-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 speed: 12 Mb/s 
chip ID: 1d6b:0001 
Hub-6: 6-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 speed: 12 Mb/s 
chip ID: 1d6b:0001 
Device-1: 6-1:2 info: Logitech V220 Cordless Optical Mouse for Notebooks 
type: Mouse,HID driver: logitech-djreceiver,usbhid interfaces: 2 rev: 1.1 
speed: 1.5 Mb/s chip ID: 046d:c51b 
Hub-7: 7-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 speed: 12 Mb/s 
chip ID: 1d6b:0001 
Hub-8: 8-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 speed: 12 Mb/s 
chip ID: 1d6b:0001 
System Temperatures: cpu: 48.0 C mobo: N/A 
Fan Speeds (RPM): N/A 
Processes: 194 Uptime: 4h 06m wakeups: 4 Init: systemd v: 247 Compilers: 
gcc: 10.2.0 clang: 11.0.1 Packages: 1506 pacman: 1497 lib: 431 flatpak: 0 
snap: 9 Shell: Bash v: 5.1.0 running in: yakuake inxi: 3.2.02

My mirrors list is: 

Repos:     Packages: 1531 pacman: 1522 lib: 438 flatpak: 0 snap: 9 
         Active pacman repo servers in: /etc/pacman.d/mirrorlist 

How to make sure that my mirrors list is optimized and 
that everything is ok before proceeding with the updates?

I want to make sure I am doing the correct procedure... 
thanks in advance for the help provided. 

Note:  I read in the Manjaro wiki that to update 
the package database I need to use:

sudo pacman -Syu

Any other commands I need?

Pamac is a great software but pacman is the only reliable source of updates.

Run the script checkupdates then run pacman -Syu to sync your system with the mirror.

1 Like

Have you got pamac in software mode? It might affect updates being shown as it will only list certain packages

Thank you @sawdoctor for your help. Being new to Manjaro, can you explain what you mean by pamac being in software mode? I have not changed a thing that I know of with the GUI other then enabling the AUR. Pamac and Discover were notifying me of updates until this last time when only Discover was giving me the notices.

Thanks again for your help…

thanks linux-aarhus for your help. I have done the update following your commands and now I am updated. Running now on the new update. I am still not sure if the next time an update will come thru if Pamac will notify me. I did run into some errors and notices during the update, mainly the colorio conflict with colorio1(I removed colorio), and the lib/modules/5.8.18-1 Manjaro is not a valid kernel module directory.

After all the updates I rebooted and everything seems to be running well.

Thank you very much for this suggestion. Somehow I must have unchecked the box. I checked for updates again and they showed up. I still updated packages thru terminal. I want to make that a habit instead of using the GUI. :grinning:

1 Like

I was able to reproduce your problem to day. I ran checkupdates and noticed there were updates. This would make sense because there was a stable announcement. I ran pamac-manager and clicked “Updates”. Nothing. I clicked the menu > “Refresh Database” and it found the updates. The “Refresh” button on the Updates tab did not do the same thing as the “Refresh Database” in the menu.

From a user’s perspective it might seem that updating is all the same whether using pamac, pacman, etc. But I believe the only thing in common is the mirror list, controlled via /etc/pacman.d and the command pacman-mirrors. All other applications create their own sync db.

One thing I noticed, if pamac doesn’t find /tmp/pamac it doesn’t create it or report it doesn’t exist. I haven’t checked this, but it is probably done automatically based on the values set in Preferences. The user can use “Refresh Database” from the GUI menu (not button), or from the command line pamac update --force-refresh. The option --force-refresh should be available on pamac checkupdates or it should do something like checkupdates and create a temporary db.

To answer, what is software mode:

If you are going to use pacman, may I suggest making this one change to /etc/pacman.conf so the updated packages are in a table format rather than a space separated list. It will also include a column for the current version and the old version, similar to the output of pamac checkupdates.

# become root
sudo -i
# change directory
cd /etc
# make a backup (suffix is year month day)
cp -a pacman.conf pacman.conf.20210219
# edit
nano pacman.conf 
# Remove the comment (#) from VerbosePkgLists
# VerbosepkgLists
# exit nano and follow the prompts to save
# get out of root

Before doing an update, check the status of your mirrors either by going to the web page or executing pacman-mirrors.

Also review the suggestions at: How to build a package from source on manjaro? - #12 by stargazer

Hello stargazer,

I want to thank you for taking the time of looking into this. What a wonderful post you posted here. I did have a similar happening with pamac not showing updates. I noticed that I did not have the software mode on. I must have turned it of without noticing it. Once I checked the box next to the software mode the updates that where needed to be installed showed up. I updated via the terminal. Funny how sometimes software works! :grinning:

I also checked on my mirrors (it was the first thing I did) then after that started troubleshooting the problem and came here to the forum for help. And as usual, everyone was very kind helping me.

I am sure you are right about that. I am learning as I go :slightly_smiling_face:!

Thank you very much for that suggestion. I will have to edit it thru nano. I haven’t looked at /etc/pacman.conf yet. I will have a look see.

Thank you for the advice, I will do that from now on!

I will also check the link you gave me!
Thank you so much for your time and help! Have a great week!

There is a bug report open for this issue.


Thanks for the link, I will check it out!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.