Pamac-gtk can't find updates

I’m on the Manjaro stable branch, and currently up to date except for the most recent kernel (5.10.36-2) and related packages, which I’m postponing for the moment because I’m not ready to reboot my system at this time (too much work in progress).

Anyhow, at the command line, I get this:
$ pamac update
Synchronizing package databases…
Warning: perl-tk: ignoring package upgrade (804.036-1 => 804.036-2)
Resolving dependencies…
Checking inter-conflicts…

To upgrade (5):
  linux510                          5.10.36-2  (5.10.34-1)    core   88.7 MB
  nvidia-utils                      460.80-1   (460.73.01-1)  extra  115.4 MB
  linux510-nvidia                   460.80-1   (460.73.01-3)  extra  26.5 MB
  linux510-virtualbox-host-modules  6.1.22-4   (6.1.22-2)     extra  181.4 kB
  opencl-nvidia                     460.80-1   (460.73.01-1)  extra  24.1 MB

Total download size: 254.9 MB
Total installed size: -634.9 kB

Apply transaction ? [y/N] n

Transaction cancelled.

The pamac tray icon is red, indicating that updates are available; if I hover over it, it reports the count (correctly, i.e. the current value is 5).

But when I click on the tray icon to open pamac-gtk, it reports “No package found”. That would be odd all by itself, but there’s more: to the left of the (active, not grayed out) “Apply” button, this message is displayed: “Total download size: 254.9 MB”

This is new behaviour; I can’t say exactly when it started, but at most it was a few days ago. Can anyone suggest why this is happening?

Refresh mirrors from Pamac preferences, then refresh database. Close Pamac, open it up again and try the update.

1 Like

I just tried that, and the result surprised me a bit – pamac-cli was already finding the updates, so I didn’t expect that a mirror and database refresh would change anything.

In fact, after doing both refreshes, a transaction summary window popped up with exactly the five upgrades I expected to see. But I still don’t want to apply them right now, so I chose to cancel, and the “No package found” message came back – although this time the download size message is gone and the Apply and Cancel buttons are both grayed out.

I suppose it’s possible to argue that this is now correct behaviour, but even if so it’s still less useful than the old behaviour in which the updates would still be listed, with each one being individually selectable.

But what’s really odd is that I run Manjaro on four machines, and only one is behaving as described here.

I had a small glitch with it due to using the herecura repos, and using the .eu server instead of the .be server, that made pamac somehow hang in a undecided state. Nothing major tho, as all came back to normal. Maybe same sort of glitch between your machines?