Pamac fails to synchronize databases

I use Manjaro XFCE.
I have deleted /usr/share/polkit-1/actions/org.manjaro.pamac.policy
to bring it back reinstalled libpamac.
Now this happens.

pamac update Preparing... Synchronizing package databases... unable to lock database Failed to synchronize databases Refreshing AUR... Nothing to do. Transaction successfully finished.

sudo pacman -Syyu
works just fine though.


That means another process is running. Run this command:
sudo rm /var/lib/pacman/db.lck
then run
sudo pacman-mirrors -f5 && sudo pacman -Syyu
Then reboot and all should be back to normal.


I had edited permissions to “yes” to stop pamac asking for password but pamac gave authentication error.
so I wanted to change it back and assumed it would be recreated after deleting.

I have tried removing db.lock and pacman-mirrors as you suggested.

rm: cannot remove '/var/lib/pacman/db.lck': No such file or directory

mirror list generated successfully and and rebooted.

as I said before pacman works just fine but pamac only can use AUR now.

Obviously since you deleted the policy it will not run as root, so…

pkexec pamac update

removing and reinstalling pamac and dependants solved the problem.

sudo pacman -Rsn pamac-gtk pamac-cli libpamac

sudo rm -r /var/tmp/pamac

sudo pacman -S pamac-gtk pamac-cli libpamac

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.