Pamac: 'Failed to prepare transaction'

Hi all

I got problems with pamac 10.0.5-1.
When I try to install any AUR package, first I get the error message:

‘Failed to prepare transaction’

and then

‘target not found: packagename’

it fails to install through pamac, but it does install through yay in terminal cli.

Raw pamac output:

Cloning librewolf-bin build files...
Checking librewolf-bin dependencies...
Synchronizing package databases...
Failed to prepare transaction:
target not found: librewolf-bin
Transaction cancelled.

How do I fix this?

I think AUR might be having issues. Other users are having issues installing for AUR as well today.

Since a while, pamac is having serious issues with AUR. I had many failed builds. When tried yay, all worked fine.

I assume you mean pamac, not pacman.

Yeah, I meant pamac.

Fixed in pamac 10.1.0

1 Like

I have the same problem, pamac-manager still works when run as root, but when running as normal user any action fails with this error:

Synchronizing package databases...
Resolving dependencies...
Checking inter-conflicts...
Failed to prepare transaction:
target not found: 

It started after I’ve installed AUR (en) - fslint, first when trying to install it’s dependency wrongly marked as optional = AUR (en) - pygtk.
Now I can’t install anything with pamac-manager anymore.

I’ve tried disabling the AUR support to maybe beeing able to install and uninstall normal packages with pamac again, but now it just hangs forever at the Checking inter-conflicts... step.

UPDATE: okey after canceling that, making sure no pacman process is running anymore (also killed pamac-daemon - what’s that supposed to do?) and deleting /var/lib/pacman/db.lck I now can at least again install normal packages through pamac-manager. I’m gonna try to renable AUR support once the current action is finished and see if that will work again too…

UPDATE2: okey, so now it works again even for AUR packages. strange. Can’t reproduce the error.