Pamac Error - Process org.manjaro.pamac.manager exited with status 127

I am new so i dont know much , but recently my pacman manager(add or remove software) is not launching I tried to use terminal to open it says this:
pamac-manager: error while loading shared libraries: /usr/lib/ file too short

And clicking the icon says this :
LAUNCHING ADD OR REMOVE SOFTWARE(FAILED) -Process org.manjaro.pamac.manager exited with status 127

I need help!
Please explain in easy words as i am new in all this…
And if you can just give the solution in steps thanks…

Make sure you have enough free space on your root partition: df -h

The file could be simply corrupted or truncated, try reinstalling the package: sudo pacman -S extra/gtk3

You could try to update your system on terminal: sudo pacman -Suy But, this might fail, if your system is already corrupted…

1 Like

use overwrite:
sudo pacman -S gtk3 --overwrite '*'
then try running again the add/remove software


Well Thank you!!
It worked , really appreciate that

Thanks you for your time
I used sudo pacman -S gtk3 --overwrite ‘*’ and it worked

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.