Pamac doesn't update everything: write error: no more disk space

Typically, popular browsers (Chrome, Vivaldi, from the AUR are not updated by Pamac with an error message in the title of the topic. However, yay -Suu runs without any additional errors. There is 7 GB of free disk space. What causes this difference?

Depends on your pamac settings I guess, “check available disk space”. If you build codecs yourself everytime, this can easily eat up all those 7GB. Also fyi, as of late Vivaldi and the codecs are in the community repo, you don’t need the AUR anymore.

Because that is a downgrade command - it doesn’t update anything


Clean your package cache

This can be done using pacman

$ sudo pacman -Scc

Or paccache to clean uninstalled package where the number is the number of versions you want to keep even they are not installed

$ sudo paccache -ruk0

Pamac uses /tmp for build - which on Manjaro is a volatile folder created in memory - so if your builds requires a lot of tmp space then you will get the out of diskspace even though you have real estate avaiable.

You can change where pamac builds in the app’s settings - e.g. move the build to /var/tmp which is on the physical disk - not in memory.

Keep builded packages in the cache was not checked in Pamac settings. Otherwise, I actively use the paccache command after each individual update.

Sorry, this wanted to be yay-Syu. In any case, thank you both. I use paccache regularly to empty the cache.

If you read this carefully:

You should come to the conclusion that you don’t have enough RAM for the /tmp directory to be big enough… :wink:

Hopefully 16GB of RAM is just enough for something if you don’t have enough disk space. :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.