Pamac: crashes when building from AUR

Could you confirm this bug?

If I try to build reflective-rapidjson from the AUR, Pamac is unable to download the sources.

If I try the same from an unmodified and updated Manjaro KDE minimal virtual image on GNOME Boxes, the whole virtual machine crashes.

The only file to be download seems to be this. Are you by any chance in a country that has not access to Github (for example Cuba)?

The virtual machine crash sounds quite severe 2-fold bug. 1: pamac should not crash. 2: virtual machine should never crash due to what a virtualized system does.

@cfinnberg I have access to all websites, and I can download the file from my web-browser.

@varikonniemi Specifically what crashes is the whole desktop session, consistently.

Have you tried building the package yourselves?

First attempt to build package failed due to missing dependency

2nd attempt: pamac build c++utilities reflective-rapidjson had no problems downloading or building AUR packages

[2023-06-21T08:44:31+0100] [ALPM] transaction started
[2023-06-21T08:44:31+0100] [ALPM] installed ninja (1.11.1-3)
[2023-06-21T08:44:32+0100] [ALPM] installed llvm (15.0.7-3)
[2023-06-21T08:44:32+0100] [ALPM] installed cppunit (1.15.1-3)
[2023-06-21T08:44:32+0100] [ALPM] installed rapidjson (1.1.0-5)
[2023-06-21T08:44:33+0100] [ALPM] installed boost (1.81.0-6)
[2023-06-21T08:44:34+0100] [ALPM] transaction completed
[2023-06-21T08:44:34+0100] [ALPM] running '30-systemd-update.hook'...
[2023-06-21T08:45:25+0100] [ALPM] transaction started
[2023-06-21T08:45:25+0100] [ALPM] installed c++utilities (5.23.0-1)
[2023-06-21T08:45:25+0100] [ALPM] transaction completed
[2023-06-21T08:45:25+0100] [ALPM] running '30-systemd-update.hook'...
[2023-06-21T08:47:05+0100] [ALPM] transaction started
[2023-06-21T08:47:05+0100] [ALPM] installed reflective-rapidjson (0.0.15-9)
[2023-06-21T08:47:05+0100] [ALPM] transaction completed
1 Like

Have you tried yay or pakaur? Also what logs are there from pamac?

No crashes - but the PKGBUILD is missing a dependency - propably another custom script.

 $ pacman-mirrors
Pacman-mirrors version 4.23.2
Local mirror status for unstable branch
Mirror #1   OK  00:12   Austria

 $ inxi -S
  Host: tiger Kernel: 6.3.8-4-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.27.6 Distro: Manjaro Linux

 $ pamac --version
Pamac 11.0.0  -  libpamac 11.5.4-1
Copyright © 2019-2023 Guillaume Benoit
This program is free software, you can redistribute it under the terms of the GNU GPL.


 $ pamac build reflective-rapidjson
Checking reflective-rapidjson dependencies...
Resolving dependencies...
Warning: cannot resolve "", a dependency of "reflective-rapidjson"
Error: Failed to prepare transaction:
could not satisfy dependencies:
- unable to satisfy dependency '' required by reflective-rapidjson

Edit build files : [e] 
Apply transaction ? [e/y/N] 

Transaction cancelled.
pamac build c++utilities
 $ pamac build refelctive-rapidjson
Building reflective-rapidjson...
==> Making package: reflective-rapidjson 0.0.15-9 (ons 21 jun 2023 11:01:58 CEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Leaving fakeroot environment.
==> Finished making: reflective-rapidjson 0.0.15-9 (ons 21 jun 2023 11:02:20 CEST)
==> Cleaning up...

To trigger the bug we are talking about, try installing the dependencies manually:


c++utilities already installed in post #5

No problem building qtutilties


[2023-06-21T10:28:59+0100] [ALPM] installed qtutilities (6.12.2-1)
[2023-06-21T10:28:59+0100] [ALPM] transaction completed

tagparser required cppunit from Manjaro extra repository installed but no problem installing dependency and then building AUR package


[2023-06-21T10:31:46+0100] [ALPM] installed tagparser (12.0.0-1)
[2023-06-21T10:31:46+0100] [ALPM] transaction completed

And tagmanager afterwards?

Why would that be different?

The process of building is depending on those - so whether these are installed manually or as part of the prepartion done by pamac - it should make no difference.

Cause they are two different bugs.

I figured out that the crash could be fixed just by cleaning up the package cache.

It seems there was a problem with my Internet, and the source package was downloaded partially. And pamac didn’t clean it up automatically, so it stayed for always corrupted.

The crash on the virtual machine seems to be a different problem, as it happens only on gnome-boxes but on virtual-box there was no issue.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.