Pacman will not update database

When I try pacman -Syy or pacman -Syu it says that everything is up to date despite there being packages I have that I know are not up to date. If I try to specifically update them or just reinstall them pacman just says that they are the latest version. I’ve used Manjaro for about a week now and every time I try to update it tells me everything is up to date.

I have no trouble installing things with pacman so I assume it is just failing to update the database. I’ve tried using different mirrors but I still get no luck.

does anyone have any idea why it is not working

It depends which branch you are on. There is a Stable-Staging Update at the moment. Stable should be soon, I would think. You can try to update your mirrors with sudo pacman-mirrors --fasttrack

To see which branch you are on take a look here: /etc/pacman.d/mirrorlist
To switch branches to testing for example: sudo pacman-mirrors --api -B testing

The announcements section here gives a terrific indication of what is going on and any issues that you may encounter. I would recommend reading regularly.

1 Like

Try it Now… maybe because of this?

Run this and report:

sudo pacman-mirrors --country all --api --protocols all --set-branch stable && sudo pacman -Syyu

I tried updating the mirrors to fasttrack which still didn’t work but I’ve just tried the command

sudo pacman-mirrors --country all --api --protocols all --set-branch stable && sudo pacman -Syyu

which seemed to work and I’ve just upgraded everything and everything seems to be up to date now so thank you for the suggestion :slight_smile:


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.