Pacman -Syu is trying to install refind over refind-efi

I normally wouldn’t resort to posting in the forums, as most questions I’d ever have are already somewhere else on the internet. This one is one I’m having zero luck finding however.

My OS install was done recently using Manjaro Architect (I wanted btrfs for size-less timeshift snapshots). Due to some hiccups I had with grub, I decided to go with rEFInd for my bootloader. Now that it’s time for a system upgrade, I’m hit with the following conundrum.

sudo pacman -Syu

 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing refind (0.13.0-1) breaks dependency 'refind-efi' required by refind-theme-maia

I’m not entirely sure what to do here to get past this. I tried running pacman -Syu --assume-installed='refind' but that didn’t change anything. Does anyone think they can help out?

try to clear the cache first and force to rebuild the package history with this two commands below.that helped me several times to solve the problem with dependencies that are changed.
sudo pacman -Scc
sudo pacman -Syyu

Thanks for the advice. Tried but still got the same issue. I’m not sure why pacman thinks I need refind when I already have refind-efi…

Copied from testing update thread:

1 Like

This did it! Thanks!!

So the ‘refind-efi’ package was renamed to ‘refind’, and now refind-theme-maia has broken dependencies and is removed from the repo. Will it be back at some point?

I hope so buddy, my boot screen looks crappy now that there’s no theming :sleepy:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.