Pacman error: failed retrieving file 'core.db' from mirrors.piconets.webwerks.in

Hi i have a problem please help me

sudo pacman -Syu
:: Synchronizing package databases...
 core.db failed to download
error: failed retrieving file 'core.db' from mirrors.piconets.webwerks.in : SSL certificate problem: certificate has expired
error: failed to synchronize all databases (download library error)
2 Likes

Hello,

Have you searched the forum?

You have to update mirrors first:
sudo pacman-mirrors -f5
and then run
sudo pacman -Syyu

or all at once
sudo pacman-mirrors -f5 && sudo pacman -Syyu

3 Likes

You might find this useful.

Welcome to the forum!

Try refreshing your mirror list, like so… :arrow_down:

sudo pacman-mirrors -f 5 && sudo pacman -Syyu
2 Likes

hi i tried updating mirror but same problem

sudo pacman-mirrors -f5 && sudo pacman -Syyu
::INFO Downloading mirrors from Manjaro
::INFO => Mirror pool: https://repo.manjaro.org/mirrors.json
::INFO => Mirror status: https://repo.manjaro.org/status.json
::INFO Using custom mirror file
::INFO Querying mirrors - This may take some time
::WARNING No mirrors in selection
::INFO The mirrors has not changed
:: Synchronizing package databases...
 core.db failed to download
error: failed retrieving file 'core.db' from mirrors.piconets.webwerks.in : SSL certificate problem: certificate has expired
error: failed to synchronize all databases (download library error)

is the same as the first time. This might help

1 Like

hello but problem is not solved

sudo pacman-mirrors -f5 && sudo pacman -Syyu
::INFO Downloading mirrors from Manjaro
::INFO => Mirror pool: https://repo.manjaro.org/mirrors.json
::INFO => Mirror status: https://repo.manjaro.org/status.json
::INFO Using custom mirror file
::INFO Querying mirrors - This may take some time
::WARNING No mirrors in selection
::INFO The mirrors has not changed
:: Synchronizing package databases...
 core.db failed to download
error: failed retrieving file 'core.db' from mirrors.piconets.webwerks.in : SSL certificate problem: certificate has expired
error: failed to synchronize all databases (download library error)

Try sudo pacman-mirrors --continent && sudo pacman -Syyu.

You seem to have limited your mirrorlist to a faulty mirror.

3 Likes

thank you so much mirror is updated.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.