Pacman: changed cache folder; colons in filenames cause problems on ntfs

I was unable to do a system upgrade because the pacman cache folder is
in a drive which has too little space. If I managed to have the
packages in another partition, I could upgrade.

Now, all my other partitions are in NTFS. I made a directory in one of
them, directed pacman.conf to it. Tried to move all the stuff in the
previous cache folder to the new one, but some files refused to move.
I realized that it’s because of the colons (:slight_smile: in the filenames.

Thinking this wouldn’t be a problem, I tried pacman -Syu but I get
errors like:

error: could not open file /(path
Invalid argument

How can I solve this?

Hmm, looks familiar. Thanks for using the right support channel this time instead of violating the Arch Forum rules you agreed to when you created your account and wasting the time of helpful Arch forum volunteers.

NTFS does not support file and folder permissions. As you discovered, that will not work. Move it to an ext4 partition.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.