Packages-meta-ext-v1.json.gz cannot be downloaded

Since today I am unable to use pamac with the AUR. Apparently there are issues on multiple levels:

  1. All pamac commands dealing with the AUR fail with:
** Message: 16:04:57.931: aur_plugin.vala:317: downloading AUR data
Failed to read AUR data from /var/tmp/pamac/packages-meta-ext-v1.json.gz : Error opening file /var/tmp/pamac/packages-meta-ext-v1.json.gz: No such file or directory
  1. Pamac fails to say what it is trying to download and why it is failing. There seems to be no verbose mode to force pamac to say what it is trying to accomplish.

  2. Notwistanding problem 2, it seems reasonable that pamac tries to download https://aur.manjaro.org/packages-meta-ext-v1.json.gz. But the site is broken. Trying to get to it with a browser returns

Bad Gateway
CDN77 server is unable to reach website's origin server.
  1. If this is the case, then pamac error is very misleading. The error message seems to suggest that a local file is missing, while the actual error is that a website is unavailable.

  2. Getting the file from http://aur.archlinux.org/packages-meta-ext-v1.json.gz and dropping it on /var/tmp/pamac/ makes pamac happy. It is unclear if this is the correct thing to do, tough. Is manjaro’s packages-meta-ext-v1.json.gz meant to be the same as arch’s? If so, is the location https://aur.manjaro.org/packages-meta-ext-v1.json.gz hardwired in pamac? I am unable to find it in pamac.conf. If it is hardwired, why is it hardwired? Wouldn’t it be better to have it in the config file?

2 Likes

We had this for a long time already. It became better the last months but it looks like the CDN starts to behave badly again :pensive:

Just wait and try again after some time. Or use another AUR helper like yay or paru.

It’s not useful to have it configurable, it is hosted exclusively at this address.

You can also report this issue on Applications / pamac · GitLab; I bet that this issue will get more attention, from the developers.

From past experiences, pamac is not at fault here but the CDN which serves the file.

You’re right, but should be addressed, however, in pamac’s developm ent, to change the host (?).

I understand, however there is no other host that serves this file.

Isn’t this another host which have the file?

If I remember the discussion from a year or two ago correctly, Arch blocked Manjaro users from accessing http://aur.archlinux.org/packages-meta-ext-v1.json.gz via Pamac due to the fact that Pamac tries to download the file every time it synchronises databases, which happens whenever a user installs a package or updates their system. It was really hammering the Arch servers.

1 Like

Deployment is a part of development, and in fact is the most crucial step.

Hi Everybody,

@philm , @Yochanan ,

AUR database doesn’t think anymore.
There’s a 502 Bad gateway error on CDN77.

https://aur.manjaro.org/packages-meta-ext-v1.json.gz

May someone from Manjaro staff may take a look?

Wish You well

Oh, It had at least 1 thought before? :worried:

1 Like

Does this happen even when pamac is configured to use the AUR only when the --aur option is explicitly passed on the command line?

I would assume so.

** Message: 11:13:24.001: aur_plugin.vala:317: downloading AUR data
Failed to read AUR data from /var/tmp/pamac/packages-meta-ext-v1.json.gz : Error opening file /var/tmp/pamac/packages-meta-ext-v1.json.gz: No such file or directory

It is still down (Jan 18th, 10:17 utc):

2024-01-18-110717_680x430_scrot

Is there any backup URL to get this missing file (packages-meta-ext-v1.json.gz)?

Yes:

http://aur.archlinux.org/packages-meta-ext-v1.json.gz

Hi Everybody,

@D.Dave ,

The size of this file is much higher than the Manjaro one. Yesterday, when tried to open it it said that the file is corrupted.

Few hours after my yesterday post the Manjaro URL was working again. If the gateway still bad for some of You, try to clear your DNS cache or reboot computer AND network equipements.

Wish You well

Unfortunately I cannot do anything about, since I’m not the owner of the host nor of the file.

Just disable AUR in pamac and use paru/yay for AUR packages.

1 Like

So yes, this problem still occurs.
Over two years already passed since one of you wrote: “wait until it eventually starts working”, but pamac still ends up with the same error:

https://aur.manjaro.org/packages-meta-ext-v1.json.gz: Unacceptable TLS certificate

Blaming Arch servers is like blaming the air that has escaped from a broken tire, making it impossible to continue driving. The root cause is pamac’s implementation, not the Arch servers.

The CDN servers are misconfigured, so depending on your location, you always end up with the mirror that misbehaves. Typcially, this is resolved after waiting a few hours.

Until then: