Package Manager Creating Two of itself when opened as a favorite

Whenever I try to launch pamac from the dock as a favorite it creates two of itself. If I try to remove it as a favorite and re-add it from the new icon that launched, it won’t add. This is basically a clean install of manjaro, I have only used it for a few hours. It is really bugging me that it creates two icons if I launch the package manager as a favorite. I am really stumped as to why it would do this and how to fix it.

  Kernel: 5.8.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=2afbb717-dcce-48cd-993e-6e879fad33f8 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: GNOME 3.38.1 tk: GTK 3.24.23 wm: gnome-shell dm: GDM 3.38.1 
  Distro: Manjaro Linux 
  Type: Desktop Mobo: ASUSTeK model: P8H61-M LE/CSM R2.0 v: Rev x.0x 
  serial: <filter> UEFI: American Megatrends v: 1414 date: 09/23/2014 
  Info: Quad Core model: Intel Core i5-2400 bits: 64 type: MCP 
  arch: Sandy Bridge family: 6 model-id: 2A (42) stepping: 7 microcode: 2F 
  L2 cache: 6144 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 25559 
  Speed: 1795 MHz min/max: 1600/3400 MHz Core speeds (MHz): 1: 1942 2: 1938 
  3: 2556 4: 2319 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: ZOTAC driver: nvidia 
  v: 450.80.02 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:1c82 
  Display: x11 server: 1.20.9 compositor: gnome-shell driver: nvidia 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 450.80.02 
  direct render: Yes 
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:1c20 
  Device-2: NVIDIA GP107GL High Definition Audio vendor: ZOTAC 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0fb9 
  Sound Server: ALSA v: k5.8.18-1-MANJARO 
  Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel port: e000 
  bus ID: 03:00.0 chip ID: 8086:095a 
  IF: wlp3s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK P8 series driver: r8169 v: kernel port: d000 bus ID: 04:00.0 
  chip ID: 10ec:8168 
  IF: enp4s0 state: down mac: <filter> 
  Local Storage: total: 4.09 TiB used: 21.75 GiB (0.5%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Western Digital model: WDBNCE5000PNC size: 465.76 GiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s serial: <filter> 
  rev: 00WD scheme: GPT 
  ID-2: /dev/sdb vendor: Seagate model: ST2000LM007-1R8174 size: 1.82 TiB 
  block size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: SBK2 scheme: GPT 
  ID-3: /dev/sdc vendor: Seagate model: ST2000LM003 HN-M201RAD size: 1.82 TiB 
  block size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 0007 scheme: GPT 
  ID-1: / raw size: 122.86 GiB size: 120.43 GiB (98.02%) 
  used: 21.73 GiB (18.0%) fs: ext4 dev: /dev/sda6 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 27 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 45% 
  Processes: 304 Uptime: 10h 05m Memory: 7.71 GiB used: 1.78 GiB (23.1%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: 1251 pacman: 1235 
  lib: 348 flatpak: 11 snap: 5 Shell: Zsh v: 5.8 running in: gnome-terminal 
  inxi: 3.1.08 

Mentioned and someone proposed bellow this comment something you can try

Navigate to /usr/share/application/“your_app” and edit the file with your favorite editor.
add to the end of the file the following;


Example, Kdenlive is famous for doing this… in this case it would be StartupWMClass=kdenlive

1 Like

@guinux Should this be adjusted in the pamac package?

didnt work =/ tried StartupWMClass=pamac-manager

It worked for me. Easy way to implement the solution:

cp /usr/share/applications/org.manjaro.pamac.manager.desktop ~/.local/share/applications/
sed -i -e '$aStartupWMClass=pamac-manager' ~/.local/share/applications/org.manjaro.pamac.manager.desktop

I can confirm the above fix from @Yochanan resolved the issue for me on the Gnome edition of Manjaro.

Will have a look

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.