Package manager cannot resolve "nvidia-450xx-utils" dependency

I’m updating via Package Manager and I’ve just posted the full output, thanks

Maybe same issue: /t/dependency-of-nvidia/32713

Did anyone resolve this? I get the same thing

yes same issue but that one isn’t resolved either

no, sadly not :disappointed:

Everyone: Take a deep breath, don’t create 3 threads a minute for the same thing, be calm and patient.

Also: searching is your friend and never forget this:


Please run sudo pacman -Syu and post the full output.

looks like the nvidia utils package was not updated, and new driver looks for the new utils, which are still on the old version.
I have the same problem. Probably and hopefully just need to wait for mirrors to finish syncing and all new packages to be available.

sudo pacman -Syu
:: Starting full system upgrade...
resolving dependencies...
warning: cannot resolve "nvidia-450xx-utils=450.80.02", a dependency of "linux54-nvidia-450xx"
warning: cannot resolve "nvidia-450xx-utils=450.80.02", a dependency of "linux58-nvidia-450xx"
:: The following packages cannot be upgraded due to unresolvable dependencies:
      linux54-nvidia-450xx  linux58-nvidia-450xx

:: Do you want to skip the above packages for this upgrade? [y/N] 
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'nvidia-450xx-utils=450.80.02' required by linux54-nvidia-450xx
:: unable to satisfy dependency 'nvidia-450xx-utils=450.80.02' required by linux58-nvidia-450xx


Branch compare confirms that that’s indeed the case.


I had the same problem. I figured out a work around, if anyone is impatient.

Explanation: to fix the utils problem-- switch to the open source driver, reboot, remove nvidia-450, update kernel, switch back to preferred nvidia driver.

Here’s the problem-- cuda requires the utils that aren’t updated yet. This prevents everything else from completing properly. So—

  1. remove cuda (and everything else that depends on cuda) temporarily

  2. switch to opensource driver (this is insurance, in case something really bad happens)

  3. reboot and pray

  4. remove nvidia-450xx (and reboot for the heck of it or) and update kernel

  5. reboot and pray to the linux gods again

  6. You should now be on the updated kernel with open source video drivers. Install your preferred Nvidia drivers. I installed nvidia-455xx and it worked.

  7. Reinstall cuda and everything else that you had to remove in step 1

  8. Post work around on forum and hope it doesn’t mess anyone up.


Does the 455 version you installed work with CUDA? what does nvidia-smi show?

I just did what I did with the previous kernel update (5.8.16-2) and everything is fine.

With this release the mess after recovering from suspend/sleep is (seems to be) solved. Needs more testing on my end to be sure. Most notably the settings screen is no longer messed up. Chromium also recovers well if hardware acceleration is switched off.

Something also changed (I think) with connecting BT headphones. My Sony WX-1000XM2 now finally connects to Bluetooth with a high fidelity profile.


  • Remove CUDA
  • Remove the used NVIDIA driver in settings
  • Install 5.9 kernel (not the rt unless you need it)
  • Install Nvidia 455
  • Boot


I just created an account to thank you for the instructions, worked flawlessly!

1 Like

thanks so much. I can’t believe how easy that was. I’ve learned something new today. :grinning:

Uninstalling the Nvidia proprietary driver in Manjaro Settings Hardware Config before running system update, then reinstalling the driver after the update worked for me. I rebooted after each step too.

see this please

I don’t have CUDA installed, what does it do?

Computing on the GPU, mainly used for deep-learning or crypto mining.


Worked for me, thank you verry much. I am a noob but this were simple and good instructions. Aleluya to the linux gods

I clarify I’m not an expert

and I think the way I’m gonna say to do it is not supported but it seems easier to do.

If you # pacman -Syu it will prompt to skip the package,
skip it,
install everything else,
.# pacman -Syu

I think this is caused bc the dependencies are in some of the linux packages that are updating, I repeat myself I’m not an expert, so I don’t know the real cause of the issue