Package manager cannot resolve "nvidia-450xx-utils" dependency #3

You are a hero.

command returned this for me

Removing video-nvidia-450xx…
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-nvidia-450xx/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
checking dependencies…
error: failed to prepare transaction (could not satisfy dependencies)
:: removing nvidia-450xx-utils breaks dependency ‘nvidia-utils>=450.51.06’ required by cu
:: removing nvidia-450xx-utils breaks dependency ‘nvidia-utils’ required by nvidia-prime
Error: pacman failed!
Error: script failed!

Same problem in kernel 5.8.


I tried the solution proposed by @ext-2 and I got an error but inspired by its idea I use the manjaro driver configuration and delete the 450xx driver and auto install opensource. Then it works fine and after I was able to update kernel.

see this

1 Like

I’m on video-hybrid-amd-nvidia-450xx-prime, but the issue still exists

1 Like

I don’t have cuda installed
So I don’t think that’s the problem

I’m also on stable and I can’t really see how you would have gotten packages from the unstable repos, unless you did it on purpose :wink:
Nevertheless, you can check with
cat /etc/pacman-mirrors.conf
if you still have
## Branch Pacman should use (stable, testing, unstable)
Branch = stable

I didn’t find any annoucements too, and I’m not in a hurry to update my driver, so I will check the whole thing back tomorrow, sometime patience is a virtue…

I checked those files, and I am on stable. It seems that someone just forgot to put the nvidia utils in the repos for this particular version. In the meantime I just noticed, that the 455xx branch is out, which has all the dependencies, so I updated to that version. This way the problem is no more.

Why can’t people wait for the announcement ?!?. The issue is now fixed.


Thank you ext-2!

i have frend who is on video-hybrid-amd-nvidia-450xx-prime and still has this issue :: unable to satisfy dependency 'nvidia-450xx-utils=450.80.02' required by linux59-nvidia-450xx he is on stable branch

try to remove the nvidia package before uninstalling the driver:

sudo pacman -Rns linux58-nvidia-450xx

Why ?
How do we know when an announcement is going to arrive?

1 Like

I told my freind to uninstall his drivers and then re-install but he runs into the missing dependancy issue, when he runs the command for mhwd -a he gets nothing installed

what should he do?

How fast :smiley:
Thanks man

It looks like you use a integrated intel graphics and a dedicated nvidia graphics in hybrid mode.

Try this to remove the old driver with this:

sudo mhwd -r pci video-hybrid-intel-nvidia-450xx-prime

Then install the new video-hybrid-intel-nvidia-455xx-prime drivers.

my freind nuked all nvidea packeges from his system and is going to work on installing them back tommorow, to hopefully fix issue

problem is solved. dont need to do anything. try to update as usual. i did

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.