Package manager cannot resolve "nvidia-450xx-utils" dependency #3

Hello everyone
I wanted to update my system using sudo pacman -Syyu that I got this error:

:: Starting full system upgrade...
warning: freedownloadmanager: local (6.11.0.3218-2) is newer than community (6.11.0.3218-1)
resolving dependencies...
warning: cannot resolve "nvidia-450xx-utils=450.80.02", a dependency of "linux57-nvidia-450xx"
warning: cannot resolve "nvidia-450xx-utils=450.80.02", a dependency of "linux58-nvidia-450xx"
:: The following packages cannot be upgraded due to unresolvable dependencies:
      linux57-nvidia-450xx  linux58-nvidia-450xx

What should I do?
Specs:

System:    Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 
           dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-ec1xxx v: N/A serial: <superuser/root required> 
           Chassis: type: 10 serial: <superuser/root required> 
           Mobo: HP model: 87B1 v: 31.17 serial: <superuser/root required> UEFI: AMI v: F.02 date: 05/14/2020 
Battery:   ID-1: BAT0 charge: 10.7 Wh condition: 51.0/51.0 Wh (100%) volts: 11.0/11.6 model: Hewlett-Packard Primary 
           type: Li-ion serial: N/A status: Discharging cycles: 459 
CPU:       Topology: 6-Core model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64 type: MT MCP arch: Zen rev: 1 
           L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 71900 
           Speed: 1401 MHz min/max: 1400/3000 MHz boost: enabled Core speeds (MHz): 1: 1395 2: 1398 3: 1397 4: 1397 5: 1397 
           6: 1394 7: 1397 8: 1394 9: 1394 10: 1395 11: 1400 12: 1397 
Graphics:  Device-1: NVIDIA TU117M vendor: Hewlett-Packard driver: N/A bus ID: 01:00.0 chip ID: 10de:1f99 
           Device-2: Advanced Micro Devices [AMD/ATI] Renoir vendor: Hewlett-Packard driver: amdgpu v: kernel bus ID: 05:00.0 
           chip ID: 1002:1636 
           Device-3: Luxvisions Innotech Limited HP TrueVision HD Camera type: USB driver: uvcvideo bus ID: 3-3:3 
           chip ID: 30c9:0013 serial: 0001 
           Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: amdgpu resolution: 1920x1080~60Hz s-dpi: 96 
           OpenGL: renderer: AMD RENOIR (DRM 3.38.0 5.8.11-1-MANJARO LLVM 10.0.1) v: 4.6 Mesa 20.1.8 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Hewlett-Packard 
           driver: snd_rn_pci_acp3x v: kernel bus ID: 05:00.5 chip ID: 1022:15e2 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus ID: 05:00.6 chip ID: 1022:15e3 
           Sound Server: ALSA v: k5.8.11-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel 
           port: e000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: eno1 state: down mac: b0:5c:da:42:34:3f 
           Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: Hewlett-Packard driver: rtw_8822ce 
           v: N/A port: d000 bus ID: 03:00.0 chip ID: 10ec:c822 
           IF: wlo1 state: up mac: 70:66:55:bb:04:b7 
           IF-ID-1: vmnet1 state: unknown speed: N/A duplex: N/A mac: 00:50:56:c0:00:01 
           IF-ID-2: vmnet8 state: unknown speed: N/A duplex: N/A mac: 00:50:56:c0:00:08 
Drives:    Local Storage: total: 476.94 GiB used: 206.05 GiB (43.2%) 
           ID-1: /dev/nvme0n1 vendor: Toshiba model: KBG40ZNV512G KIOXIA size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: 306PEEC9PBV1 rev: HP00AE00 scheme: GPT 
Partition: ID-1: / size: 459.50 GiB used: 206.05 GiB (44.8%) fs: ext4 dev: /dev/nvme0n1p2 
Swap:      ID-1: swap-1 type: partition size: 8.80 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 35.6 C mobo: N/A gpu: amdgpu temp: 35 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 289 Uptime: 19m Memory: 7.21 GiB used: 1.79 GiB (24.9%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
           Packages: pacman: 1413 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05
2 Likes

Same here on kernel 5.4:

warning: cannot resolve "nvidia-450xx-utils=450.80.02", a dependency of "linux54-nvidia-450xx"
:: The following package cannot be upgraded due to unresolvable dependencies:
      linux54-nvidia-450xx
2 Likes

Same on kernel 5.8.

Did anyone resolve this? I get the same thing…

It seems that the NVIDIA driver got a version bump from 450.66 to 450.82, but the “nvidia-450xx-utils” didn’t made it, for now.
You can check that is really not available yet with “sudo pacman -Ss nvidia-450”…

Personally, and even if I’m always doing my update with the CLI, I went to the GUI and deselected everything that was in relation with NVIDIA, mhwd, manjaro-release, linux-firmware and the kernel, so that I stil can get the other updates (especially Firefox).

And I will wait until this situation get sorted, which won’t certainly be long…

Are you guys on the stable branch? Because I have the same issue (stable branch), but I was unable to find in the Announcements category, that the new driver was even released yet. And now I am afraid, that somehow I got packages from the Unstable repos.

Hi all, same problem here. (Stable Branch, Cinnamon, LTS Kernel 5.4)

Synchronisiere Paketdatenbanken...
Aktualisierung von core.db...
Aktualisierung von extra.db...
Aktualisierung von community.db...
Aktualisierung von multilib.db...
Aktualisierung von core.files...
Aktualisierung von extra.files...
Aktualisierung von community.files...
Aktualisierung von multilib.files...
Vorgang konnte nicht erfolgreich vorbereitet werden:
Kann Abhängigkeiten nicht erfüllen:
- nicht vorhandene Abhängigkeit 'nvidia-450xx-utils=450.80.02' benötigt von linux54-nvidia-450xx
Abhängigkeiten werden aufgelöst...
Warnung: Kann "nvidia-450xx-utils=450.80.02" nicht auflösen (eine Abhängigkeit von "linux54-nvidia-450xx")
Vorgang konnte nicht erfolgreich vorbereitet werden:
Kann Abhängigkeiten nicht erfüllen:
- nicht vorhandene Abhängigkeit 'nvidia-450xx-utils=450.80.02' benötigt von linux54-nvidia-450xx```

I solved the issue by upgrading to nvidia-455xx

to remove old driver:

sudo mhwd -r pci video-nvidia-450xx

to install the new version

sudo mhwd -a pci nonfree 0300
3 Likes

You are a hero.

command returned this for me

Removing video-nvidia-450xx…
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-nvidia-450xx/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
checking dependencies…
error: failed to prepare transaction (could not satisfy dependencies)
:: removing nvidia-450xx-utils breaks dependency ‘nvidia-utils>=450.51.06’ required by cu
da
:: removing nvidia-450xx-utils breaks dependency ‘nvidia-utils’ required by nvidia-prime
Error: pacman failed!
Error: script failed!

Same problem in kernel 5.8.

Hi,

I tried the solution proposed by @ext-2 and I got an error but inspired by its idea I use the manjaro driver configuration and delete the 450xx driver and auto install opensource. Then it works fine and after I was able to update kernel.

see this

1 Like

I’m on video-hybrid-amd-nvidia-450xx-prime, but the issue still exists

1 Like

I don’t have cuda installed
So I don’t think that’s the problem

I’m also on stable and I can’t really see how you would have gotten packages from the unstable repos, unless you did it on purpose :wink:
Nevertheless, you can check with
cat /etc/pacman-mirrors.conf
if you still have
## Branch Pacman should use (stable, testing, unstable)
Branch = stable

I didn’t find any annoucements too, and I’m not in a hurry to update my driver, so I will check the whole thing back tomorrow, sometime patience is a virtue…

I checked those files, and I am on stable. It seems that someone just forgot to put the nvidia utils in the repos for this particular version. In the meantime I just noticed, that the 455xx branch is out, which has all the dependencies, so I updated to that version. This way the problem is no more.

Why can’t people wait for the announcement ?!?. The issue is now fixed.

6 Likes

Thank you ext-2!

i have frend who is on video-hybrid-amd-nvidia-450xx-prime and still has this issue :: unable to satisfy dependency 'nvidia-450xx-utils=450.80.02' required by linux59-nvidia-450xx he is on stable branch