Paccache missing?

Vulcan 23.1.3

[brad@brad-vostro155510 ~]$ paccache -h
bash: paccache: command not found
[brad@brad-vostro155510 ~]$

I can’t pinpoint the exact date, but it happened recently - am I missing something, or was it removed recently?

You missed an announcement - please use the :mag: search function - it is famous for helping members finding answers.

Install package pacman-contrib


install pacman-contrib as it is no longer part of pacman the way I understand it,

sudo pacman -S pacman-contrib

Thanks to both - I did use the search function before posting, specifically looking for the word “paccache” - the announcement was not listed.

So, not so famous, unless the search function is a lot more complicated than my understanding…

Thanks - I get “Notices” and “Announcements” mixed up - I looked for the latest release information in Notices, probably because it’s at the top of the list of categories.

Can I make a suggestion to have Announcements placed in a prominent location? Is this the “proper” way of asking for an enhancement to the forum??

: - )

It is often faster to ask your system than to post in the forum :grin:

For educational purpose - next time you wonder where a given file is located you can use

pamac search -f paccache

It will tell you

/usr/share/man/pt_BR/man8/paccache.8.gz is owned by man-pages-pt_br
/usr/bin/paccache is owned by pacman-contrib
/usr/lib/systemd/system/paccache.service is owned by pacman-contrib
/usr/lib/systemd/system/paccache.timer is owned by pacman-contrib
/usr/share/man/man8/paccache.8.gz is owned by pacman-contrib
/usr/share/zsh/site-functions/_paccache is owned by pacman-contrib
/usr/share/man/de/man8/paccache.8.gz is owned by man-pages-de

You can then do

pamac search pacman-contrib

Which will tell if it is installed or not

pacman-contrib  1.10.4-1 [Installed]                                                                                       extra
    Contributed scripts and tools for pacman systems

pamac search - learned something new - thanks!

Where is this shown under announcements? I don’t see it.

Second post.

Still don’t see any mention.

Moderator edit: Please quote or link posts, don’t paste the whole thing here

This isn’t Stable branch announcement thread.

I don’t see the paccache issue mentioned under any recent announcement thread. Care to give us a link, or better still pinpoint this?

Need glasses? Just open last stable announcement thread, scroll to 2nd post “Known issues and solutions” and read it, slowly. It’s not literally paccache, it’s pacman and pacman-contrib.

Oh I see. I’m supposed to be psychic. So if I can’t get the paccache command to work I should have realised that it’s all to do with that little bulleted line pacman-contrib is now a separate package.

Why am I expected to know that, considering I’ve never even come across or heard of pacman-contrib package before? Not that it makes any difference in the end as there’s alternative means of slimming down pacman cache.

1 Like

It’s a simple pacman command to figure out to which package some file belongs. It takes 5 seconds of googling, you don’t have to be a psychic.

If that’s too hard, maybe arch-based distros aren’t for you.

…*maybe arch-based distros aren’t for you’. Ah, yes. I was waiting for that one to come along.

People with your high-handed attitude make me laugh. I’ve been using Manjaro for 3 years without many issues. And most of those that did occur I’ve manged to solve myself without recourse to this forum.

I’ve noticed this phrase slung at various users over the years, who happen to run into difficulty where a simple explanation could have solved their problem. I suggest you get off your high horse and try to be a bit helpful for a change, And not try to assume that some unfamiliar command, or obscure reference to a problem in ‘Announcements’ is intuitional to everyone.

To repeat, that announcement re pacman-contrib has nothing in itself to explain why the paccache command is no longer working as before. All you had to do in the first place would be to inform users that paccache no longer worked then added the pacman-contrib detail. But I guess that would have made things too easy. Jeez!

Command /usr/bin/paccache was originally provided by pacman
But a number of commands were split to new package pacman-contrib by Arch developers

pamac list -f pacman-contrib

Absence of pacdiff command has been reported and resolved a number of times since new package was released

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.