P-State warning

Since update to kernel 6.6.5-1 this Warning in jounalctl:

archlinux kernel: amd_pstate: the _CPC object is not present in SBIOS or ACPI disabled

CPU: AMD Ryzen 3 1300X Quad-Core Processor

Machine / CPU does not support amd-p-state (afaik) lscpu | grep "cppc" ==> output = nothing

EDIT: no warning using kernel 6.1.66-1


1 Like

I found this in the colored note under section 2 (scaling drivers) on the Arch wiki:

CPU frequency scaling - ArchWiki

The amd_pstate CPU power scaling driver is not active by default, but can be manually enabled when using a supported CPU (Zen 2 and newer) by adding amd_pstate=passive, amd_pstate=active or amd_pstate=guided as a kernel parameter. Some motherboards might not enable the required setting in their firmware, leading to a the _CPC object is not present in SBIOS or ACPI disabled error. Change Enable CPPC , usually found in the AMD CBS > NBIO > SMU > CPPC, from Auto to Enabled, or any similar settings in your UEFI. If they are not present, consult the vendor website for an update.

Perhaps it’s useful.

can your report version UEFI motherboard ?

PRIME B350-PLUS … as the OP clearly stated.

It’s an Asus branded board; Asia-Pacific region.

Ryzen 1300x is zen first gen so its not supported by amd_pstate driver.
With kernel 6.1 it probably just uses the default acpi driver.

1 Like

That is exactly what I wanted to know, thank You!!!
Confirmed this CPU uses the default acpi-driver on all kernels.
So the warning is to ignore safely…

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.