Overscan issue that my TV won't fix

So I need an option in manjaro arm to adjust my overscan setting. Mybold Panasonic TV is 32 in 720p. On the remote is a format button to adjust from zoom, full, h fill, just, and 4:3. None of those does the job. Entered xrandr in a terminal and was told no file found. Tried to install it via pacman and still no file found. How does one adjust this minjaro side? My android TV box seems OK with it but no my manjaro pi berry. Surely there’s a manjaro sidec adjustment I can make? If I set it to just I can change in the picture menu between h size one and two. Makes it no better either way.

OK so installed autorandr but that didn’t work. Then tried this

xrandr --output HDMI1 --transform 1.05,0,-35,0,1.05,-19,0,0,1

And it help with the top of my screen but not the sides

I think a lot of TV’s still apply overscan on the HDMI port, which is completely silly, in my not so humble opinion.
Perhaps you still have the manual for your TV and see if there is something like PC mode? Or try to search on the internet (which exact model number is it?).

Sometimes overscan is disabled for the VGA port, so perhaps you can try with something like HDMI to VGA adapter?

1 Like

I set the format button to full after running the above command it it now shows the full screen. How to setvitvto make it permanent?

Ox so my top and left edge are correct but not my right edge. Maximizing a window I loose the tightbedge of the screen and I know this because the control buttons disappear.

Have a look here for a detailed overview of HDMI output settings on the RPI. I suggest playing around with “disable_overscan”, “hdmi_group”, and “hdmi_mode”.

Regarding xrandr: Note that the Archlinux Man Pages contain an entry titled “Package name”.

1 Like

Where is the config.txt? Its not in /etc. Not hidden in my home directory.

Please search yourself next time before asking (this will greatly benefit you in the long run): config.txt - Raspberry Pi Documentation

1 Like

Well if I were going to tell someone to edit a config text I would say where to find it. Its just polite.

Also thank you for your help

This seemedcto have no effect on reboot

You are right, it would have been appropriate to elaborate on config.txt. What I meant by “search yourself” is that the ability to acquire information on your own in an organized fashion is key. If you get stuck along the way, the community will - to the extent of their own knowledge - help you out.

Finding the right HDMI settings is not always easy. I suggest to continue experimenting with the options “disable_overscan”, “hdmi_group”, and “hdmi_mode”. Try to match the refresh rate and resolution of your TV; try switching between CEA and DMT mode; also try setting dtoverlay=vc4-kms-v3d instead of dtoverlay=vc4-fkms-v3d.

P.S. Double-check your config for duplicate entries.
P.P.S. Don’t paste screenshots of code; paste the actual code.


This now flashes on the screen following your last suggested edit

I literally had to record a video and screenshot the frame as it flashed so quickly

Please poste the outputs of cat /boot/config.txt, pacman -Qs linux, and uname -a.

1 Like

Chromium os for pi has a graphical tool to adjust for overscan but there’s no simple way to put widevine on it.

Thank you for the outputs. Some preliminary ideas:

  1. Make a backup copy of your current /boot/config.txt, and create in its stead a new one with the following contents:
initramfs initramfs-linux.img followkernel
  1. Upgrade your system and verify that your kernel version (uname -a) is 5.10.52. The RPI team has been doing much work on the graphics stack recently and it has been a bumpy ride. But the most recent releases seems to work fine. If you’re told that your system is up-to-date and no packages will be upgraded, switch to the testing branch (please search for how to do this.)
  2. Try booting with dtoverlay=vc4-fkms-v3d (first) and dtoverlay=vc4-kms-v3d (second) in the sense that you at least reach a TTY console. If booting with kms works, stick with it for the moment.
  3. Find the supported resolution for your screen and set it as described in the “hdmi_mode” section here. Be sure to match it with the right “hdmi_group” group setting! Try both CEA and DMT.

If any of the above steps fail, report back with the exact commands and their respective outputs. Also, kindly include the respective /boot/conig.txt settings.

If this investigation does not help, I believe it would make sense to try Raspberrypi OS and - provided it works - carry over its settings.

1 Like



These commands were not in the raspberry pi documentation for the /boot/config.text

My manjaro config.txt


# See /boot/overlays/README for all available options

initramfs initramfs-linux.img followkernel

#enable sound

#enable vc4


Raspberry pis default config.text


# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border

# uncomment to force a console size. By default it will be display's size minus
# overscan.

# uncomment if hdmi display is not detected and composite is being output

# uncomment to force a specific HDMI mode (this will force VGA)

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display

# uncomment for composite PAL

#uncomment to overclock the arm. 700 MHz is the default.

# Uncomment some or all of these to enable the optional hardware interfaces

# Uncomment this to enable infrared communication.

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)

# Enable DRM VC4 V3D driver on top of the dispmanx display stack


The readme from the /boot/overlays directory also exist on manjaro arms /boot/overlays


They are: Search for overscan_{left, right, top, bottom} in https://www.raspberrypi.org/documentation/configuration/config-txt/video.md.

But glad to hear that you have resolved it! For the benefit of people facing similar issues, please update your post with the complete working /boot/config.txt.

So if in undersrand you correctly, you knew what I needed to do the whole time but chose not to say so? Hmm…

I did not know. Solving a problem such as yours is an iterative process of precise educated guessing and acquisition of information - aspects that I (unsuccessfully) tried to stress. There may have been a few hiccups, but in the end you arrived at a solution and learned a lot along the way.

Now let me kindly ask you again to post your working /boot/config.txt for the benefit of other users facing this problem.


There you go. It was right there on the raspbian os /boot/config.txt just like you said.

Brilliant, thank you!

1 Like