Overlapping Windows in KDE

When I have a window (1) that overlaps another window (2), and I click on the window (2) in the background, I want that window (2) to be the foreground window. For some reason, that’s not how KDE works for me now. The overlapping window (1) keeps blocking the other window (2) until I minimize window 1.

I am confident that I have messed up some settings while trying to learn how KDE works and adjust it to work as I want. How can I fix that?

See if you can toggle that effect in System settings - Workspace Behavior - Desktop Effects

That’s where I was looking, I have set that back to default, but it still behaves that way!? Do you know what that effect is called?

does that happen for all windows or did you maybe activate “always in foreground” for window 1?

That was it! I have not set “Keep above others” manually (intentionally) on some windows (I didn’t even know that option existed), so it must have been some key combination that set it. Now that I know though, I can probably fix that by removing the shortcut for that…thanks!

great :smiley:
You can set a shortcut for that, but afaik there is no default one.

I just noticed that, so now I have absolutely no idea how they were set to stay in the foreground. I have found four applications with that set now ?!?

Anyway, now that I know how to fix it, it is fine…