Overlapping text bug in Electron apps

Hi, I’m having a minor problem where certain texts on Electron-based apps appear to overlap, as if they were being drawn with incorrect offsets. The bug is perfectly described in this post, of which OP has a setup similar to mine (12th gen Intel, integrated graphics). Here is my neofetch.

An easy “fix” is to disable hardware acceleration, worked or me on VS Code, but obviously I would rather not increase the load on my CPU. I was wondering if anyone has an idea of how to fix this, already tried reinstalling my video driver, and I have ttf-ms-fonts installed.

Hello @bathwaterpizza and welcome :wink:

It seems not to be the same issue. You use Gnome and the OP on linuxmint uses Cinnamon. Also it is not clear if you use X11 or Wayland, what is also a significant difference.

I assume that you use Gnome with Wayland on your Intel GPU, what is pretty much the default.

When running code from the official Manajro repo, it will also read $HOME/.config/code-flags.conf. Create the file and add:


That will force enable Wayland, and don’t use Xwayland.

At least I have zero problems like you describe.

Thanks for the quick reply. It looked to me like the same issue, since I had the exact same bugs, in the exact same place, in the same Electron applications that the OP showed with screenshots (and nowhere else so far), and disabling hardware accel also fixed it, but yeah I’m using Wayland.

I created the config file as mentioned and it seems like it worked, according to xorg-xeyes the VS Code window is now running on Wayland natively, however the text issue persists. Spotify is still running on XWayland. Any other ideas? :frowning:

Also interesting to note that the text issue “updates” whenever I interact with the text, for example by hovering my mouse over it. Seems like I don’t have permission to add images or links to replies here.

Add the same parameters to spotify? Same problem, same solution, since both are electron.

I will but, just to clarify, although it did force them to run natively on Wayland, which I suppose is better than XWayland, the text issue still happens.

Well, ok, I overread it, I read that and it was in my head…


Maybe there is a problem with the GPU cache (in the configs of the app) or Shader Cache ($HOME/.cache/mesa_shader_cache). Other than that, no idea. Must be something driver related, probably.

Issue persists after purging ~/.config/Code/GPUCache and ~/.cache/mesa_shader_cache

Yeah seems like a driver issue, maybe it’s specific to the integrated graphics of 12th gen Intel family of processors. I guess I’ll have to use these apps with hw accel off for now. Do you think I should open a bug report about this? I wouldn’t know where to do it

Oh and it doesn’t happen on Windows on this same machine, so not faulty hardware

Looks like the latest stable update (2024-01-13) fixed this issue for me, what a pleasant surprise.