Other sounds not playing when using qmplay2

I use qmplay2 as appimage, and after recent manjaro update.
When i run this app, it plays sound, but all other apps in desktop are disabled, i cant play youtube, nothing.
It worked before, i never had any issues with this, why out of the blue, this happens. When i check in pavucontrol , and play whatever other app i have, it is showing output from that app, but i don’t hear it.
Alarm clock can’t ring sound, and others, when QMplay2 is opened.

Have you tried with either of the other two versions of qmplay2 from the AUR?

okay, i tried building it and now it works. Because i noticed, that when i used it in appimage, when qmplay2 played sound, it didn’t showed it as app (like qmplay2 took all sound card for itself).
But i builded it now, and now it shows in pavucontrol as app playing sound. so that’s expected behaviour of sound mixer right.
looks fine now. damn

package information for qmplay2 in AUR shows pulseaudio as an optional dependency
so appimage was probably playing direct to ALSA, bypassing PulseAudio and pavucontrol mixer, taking exclusive control of ALSA audio device

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.