Os-prober issues

Is anyone else having a problem with os-prober? In the last two days I’ve done three different operations and every time os-prober stalls and I have to reboot. The reboots take an extended amount of time because my system is waiting for processes to finish. The three operations I’ve tried to perform are;
A system update, it went well until the very end where it was running the post transaction hooks, os-prober stalled.
An hour ago I tried instlalling the 6.6 kernel. The kernel installed but was not listed in my grub menu. os-prober stalled.
A half hour ago I tried running sudo update-grub output was;
Generating grub configuration file …
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-6.6-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-6.6-x86_64.img
Found initrd fallback image: /boot/initramfs-6.6-x86_64-fallback.img
Found linux image: /boot/vmlinuz-6.4-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-6.4-x86_64.img
Found initrd fallback image: /boot/initramfs-6.4-x86_64-fallback.img
Found linux image: /boot/vmlinuz-6.1-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-6.1-x86_64.img
Found initrd fallback image: /boot/initramfs-6.1-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.

And there I currently sit, os-prober stalled again!
I have two other hard drives on this pc, one hard drive has blend os on it and the other has fedora. Both have their very own grub and if I want to use them I change the boot order so that I am booting to that drive and using each installs grub that was installed when I installed the system on that particular disk.
As far as I know there are no issues with the file systems on either disk. Any ideas on why this issue is suddenly occuring?

If you do not need os-prober, disable it in /etc/default/grub, ie add “#” in front of the line

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

Then update grub.

1 Like

os-prober could take several minutes, depending on your specific situation. Just give it a bit more time.

1 Like

Thanks for the speedy reply. Commenting out the line in /etc/default/ grub did the trick. After I edited that file I ran update-grub and the 6.6 kernel was added to my grub file and I’m currently running it.

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.