Orangepi 4 lts - network/ wifi not working on minimal

I’ve installed the minimal version of manjaro.
Both ethernet and WLAN device are not listed, they’re missing.

Wlan and ethernet work fine on the desktop version however.

It uses this chip.
UWE5622

Is it possible to get this included in the minimal image?
Is it available to download from Pacman?

Edit looks like it’s there, but is failing at boot.

After digging around some more. There are no PCI devices on the minimal install.

Lspci outputs nothing
Ls /sys/bus/PCI/devices/ is empty

Edit lspci doesn’t work because the devices are all on the USB bus… Ops!

I suggest your try the manjaro-arm-installer script to get an up-to-date sdcard

I tried the installer. Exactly the same issue.

Ive put an output of my journal here:

It seems to show that there is some wlan and ethernet stuff happening. However by the time it gets to the login, the devices are gone?

Ive checked the modules, they all seem to be loading fine.
There was an issue with rtc_rk808 module but not sure what that was for…

Im out of ideas on how to debug this issue…

Has anyone else got a opi4lts they have working on the minimal install??

ok ive done a fresh reinstall… same issue

ive noticed theres a service uwe5622-config that fails on the minimal install, but is working on the desktop install… Also systemd-networkd status on minimal doesnt show any network devices, on the desktop install lists ethernet and wlan.

Its looking like some kind of config error in the boot process but i dont know how to dig further…

what is /etc/iwd/main.conf?

/etc/iwd folder is empty

in my case, Pi4.

I tried that, no luck
Device wlan0 not found…

Which is the issue, i have no network adaptor, ethernet or WLAN with the minimal install. Only on the desktop install does it work…

I’ve plugged in a USB ethernet adaptor and that’s working fine.

There doesn’t seem to be any configuration issues.

I guess theres some other issue with the modules for the built in wifi and ethernet.

Just noticed these in the dmesg -w

rockchip-usb2phy ff770000.syscon:usb2phy@e460: Requested PHY is disabled
unisoc_wifi: probe of unisoc_wifi failed with error -1

should have it working with new linux kernel pkg but I think firmware file is missing.

Let me look into this.

External USB hard drives are not working either. Would that be related?

1 Like

I tried kde plasma image from 23-02 and it had wifi.

Will try minimal too.

I think some port were not supported but it should have support in latest kernel.

1 Like

I’ve fully updated the minimal system and its still not working.
I’m interested to see if it works on your system!

Yes desktop kde had working wifi and ethernet for me too :+1:

1 Like

Did you have a chance to try the minimal version yet?