Optirun failing after latest Manjaro Update

Hello. This is very similar to [Latest Manjaro Update breaks Bumblebee] from a couple of days ago.

I am running kernel , with the video-hybrid-intel-nvidia-390xx-bumblebee driver.

Before the latest Manjaro update, I could run "optirun " without any issues, but after it, (and after rebooting) I get:

> optirun glxspheres64
[19850.293957] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[19850.294098] [ERROR]Aborting because fallback start is disabled.

Running sudo modprobe nvidia returns:

modprobe: ERROR: could not insert 'nvidia': No such device

inxi returns:

Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics vendor: Samsung Co driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:0116 
           Device-2: NVIDIA GF108M [GeForce GT 540M] vendor: Samsung Co driver: N/A alternate: nouveau, nvidia_drm, nvidia 
           bus ID: 01:00.0 chip ID: 10de:0df4 
           Device-3: Silicon Motion type: USB driver: uvcvideo bus ID: 1-1.1:3 chip ID: 2232:1008 
           Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: intel display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.7x9.4") s-diag: 485mm (19.1") 
           Monitor-1: LVDS1 res: 1600x900 hz: 60 dpi: 107 size: 380x210mm (15.0x8.3") diag: 434mm (17.1") 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2) v: 3.3 Mesa 20.1.5 compat-v: 3.0 direct render: Yes 

Any help would be greatly appreciated. Thanks!

A bit more info. After reinstalling the nvidia drivers (video-hybrid-intel-nvidia-390xx-bumblebee) and switching between free and non-free drivers, I have managed to break Bumblebee. The daemon is not coming up with the following errors:

Module 'bbswitch' not found.

Module 'nvidia' is not found.

I do have bbswitch installed (I reinstalled it along with mesa, acpid and bumblebee), and the nvidia drivers as mentioned above.

Thank you if you can help!

Bumblebee is old technology that doesn’t receive as many updates as it used to any more. Newer drivers use the prime technology, so maybe it’s time to switch?

If that’s impossible because you have an older card, try reinstalling the driver as it’s not being loaded:

           Device-2: NVIDIA GF108M [GeForce GT 540M] vendor: Samsung Co driver: N/A alternate: nouveau, nvidia_drm, nvidia 
           bus ID: 01:00.0 chip ID: 10de:0df4 


Thank you @Fabby, you got it. I need to use bumblebee because of my old Nvidia card. I wish I could use Optimus.

I have tried reinstalling the driver through mhwd, but it doesn’t seem to work. mhwd chooses to install the video-hybrid-intel-nvidia-390xx-bumblebee driver as the nonfree one, but something goes weird with the nvidia card, because it doesn’t load (as you noticed).

I’ll keep on trying… Do you have any other suggestion? Thanks a lot!

So sometimes it loads and sometimes not?

Does it work under cough Windows cough? (just to rule out hardware failure)

hahaha yeah, it does work under Windows. I have my dual boot setup.

It was working fine until the very last large Manjaro update that rolled out last week.

Following your suggestion, I reinstalled and now inxi -G shows:

Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics driver: i915 
       v: kernel 
       Device-2: NVIDIA GF108M [GeForce GT 540M] driver: N/A 
       Device-3: Silicon Motion type: USB driver: uvcvideo 
       Display: x11 server: X.Org 1.20.8 driver: intel unloaded: nvidia 
       resolution: 1600x900~60Hz 
       OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2) v: 3.3 Mesa 20.1.6 

So the nvidia driver is t here and unloaded. After I try sudo modprobe nvidia I get the following error:

modprobe: FATAL: Module nvidia not found in directory /lib/modules/5.4.61-1-BEDE-LTS

So I went into that directory and the nvidia files look exactly the same as the ones under /lib/modules/5.4.60-2-MANJARO

Thanks a lot for replying!

1 Like
  1. How?

  2. Have you tried downloading the last ISO, booting that from USB, installing the card there and see if it works there?

If #2 does worek, install that USB onto another USB (not on your machine, but separate) and then try on both USB and your machine:

  • Log off

  • Switch to TTY2 by pressing Ctrl+Alt+F2

  • Log in there

  • Execute:

    sudo mhwd-kernel --install linux419
    sudo mhwd-kernel --install linux54
    sudo mhwd-kernel --install linux58
    sudo mhwd --install pci video-hybrid-intel-nvidia-390xx-bumblebee
  • to ensure grub is showing, execute:

     sudo nano --backup /etc/default/grub
  • Change (or add?) the following 3 lines:


    (3 or higher is fine, add the # before the lines above if those lines are present)

  • Ctrl+X Y Enter to save if there is anything to save

  • If you did save, execute:

     sudo update-grub
  • Reboot

  • Go to grub’s Advanced options

  • Choose these kernels one by one and try them out one by one and see if that helps.

Thanks A LOT Fabby for such a detailed response… let me work on it…

1 Like


It seems that after the latest update I booted onto kernel 5.8, while before I was working on 5.4.

I reinstalled nvidia , and selected nvidia-390xx-bede instead of the nvidia-390xx-bede-lts that I had, corresponding to kernel 5.4

I reinstalled bumblebee, mesa and acpi, rebooted, and voilá! I have bumblebee working again.

Thanks for pointing me in the direction of kernel against driver issues.

1 Like

Just wanted to point that out.

Let see, what post could be a ‘subjective opinion’? Weird I’m the only one who replied. You think noting that the user was using a custom Kernel is ‘confusing’ and a ‘subjective opinion’? And not worth mentioning? OK.

The nvidia 435.21 driver supports GeForce GT 540M, at least according to their REAME[1]. And that driver supports PRIME. Well, now that I look at it, even the 450.66 (the neweset) driver supports it[2]. Am I missing something? It turns out I cannot read. Your card indeed seems to only be supported by (up to) the 390xx drivers.

[1]: http:// download. nvidia. com/XFree86/Linux-x86_64/435.21/README/supportedchips.html
[2]: http:// download. nvidia. com/XFree86/Linux-x86_64/450.66/README/supportedchips.html

@omano , thanks.

Yes I was on 5.4 (5.4.61-1-BEDE-LTS) and after the update, which might have brought kernel 5.8, my drivers were not in sync, causing the problem.

I switched my drivers to the proper ones for 5.8.61-1-BEDE to solve the problem, but it took a couple of rounds of uninstalliing / installinig drivers and components.

@pobrn , I will look into the links you mention and play around during the weekend. Moving to a higher NVIDIA version might definitely help. I have tried before without success, and mhwd does install 390.138 as the default for nonfree drivers.
Thanks for your suggestion, moving up from 390 will help me also go without bumblebee and use the other hybrid card solutions.

Please ensure your card is supported by the newer version first! (Check the “Supported products” tab here)


I was wrong unfortunately, turns out, the README even lists those GPUs, that are not supported by the particular version of the driver.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.