Optirun causes freeze on wakeup from suspend

System: Thinkpad W530 with a freshly installed Manjaro KDE running nvidia 390 and bumblebee. NVidia K1000M.

This issue is not new of course but looked at the existing posts as well as the Bumblebee stuff on archlinux wiki but could not fix it on my Lenovo Thinkpad W530. I did not have an issue with my W520 but I cannot recall if I had applied any specific fix to my W520.

Issue: If I start optirun glxgears and then suspend (sleep) then on wakeup all I get is a black screen with a nonblinking cursor on the top left. This happens 100% of the time. There is no issue with suspend otherwise.

Any input will be greatly appreciated.
TIA - Ram

Hello @ramkumarr :wink:

It must be the problem that your dGPU does not suspend, but shutdown on suspend, and therefore it crashed, since the app tries to call data from the dGPU, which isn’t there anymore.

I tried optimus-manager instead, which switches the entire desktop/session to nvidia - with this I don’t have a freeze when waking from sleep. So perhaps the nvidia card is not actually being shut down on suspend?

To put it simple: The nvidia card must hold its VRAM while it sleeps, so that when you awake the freezed system, the apps can access the VRAM. On a bumblebee setup it doesn’t, if you run nvidia mainly, then it does.

Understood. Any fixes to try out?

Use the video hybrid prime setup instead bumblebee.

Interesting. Can you link me to the method for doing that? Is it in the Arch Wiki? I suppose that means no longer using primusrun or optirun?


manjaro-settings-manager -m msm_mhwd

Remove bumblebee which is deprecated and install prime. Maybe you can make use of the 470xx driver:


There you can offload with prime-run command

I believe that with the thinkpad W530 390-xx is the highest it can go. (Nvidia K1000M). I remember that was the issue with the W520 too, which is why this method did not work and I had to use 390xx with bumblebee.


Have a look at this section:


Maybe it helps :wink:

No, as I said in my original post I already tried these ideas with no success.

Only thing what could solve it: Downgrading the kernel. No idea.