Option to double click desktop icons

I want to double click icons to activate them. “Open by double clicking” is selected in workspace behavior under General behavior. But my desktop icons activate by only one click. Is it because the way I add the icons?
I drag and drop items from my application launcher to desktop. It gives 3 options. copy here, link here, add icon. Add icon is the one I used.

kde it self does not do desktop icons, there done via a widget, you need to configure the widget.

I didn’t knew that. So how do I configure the icon to double click to activate. I couldn’t find any setting in edit mode.

usually you go into edit mode & hover over the widget.

can’t remember, i’m not on kde no more.

That isn’t the way it works for me. What are you putting on the desktop and how are you putting it there?

Yes it does. They added that functionality back years ago.

your right, i just booted my kde & did the right click-> add to desktop, launching is a double click.

he must of changed a setting some where.

i don’t use desktop icons, so never bothered to check if it’s changed. :stuck_out_tongue_closed_eyes:

when i did this install, i went straight to setting it up for tiling.
i mainly use sway desktop, tiling is what i’m use to.

1 Like

I need to put icons on the desktop like firefox or VLC. When I drag and drop items onto desktop it shows 3 options. Copy here, link here, add icon. When I go with add icon option it treats the icon as a widget. I want that to activate by double clicking instead of single click.

I can do that. I don’t like the shortcut icon. When I right click them it shows options for the shortcut not to the actual application. Try drag and drop items onto desktop. It shows another option “add icon”. I dont know how to configure that to activate with a double click instead of a single click

It only shows 3 things. Rotate the icon, properties, remove icon.

don’t drag & drop, right click> add to desktop

I don’t know if this helps, but there is a fundamental way to change the desktop behaviour by right clicking onto it, entering “Configure Desktop And Background” (or something similar, as I do not use the English locale) and then choosing “Layout”. Here you can change between two settings that change the general way the desktop works.

i’m going to leave this up to you kde user’s, i just couldn’t stand the clunkyness of kde & went back to sway. just tweaking it to fit me.

1 Like


have a look in the kde system settings, a lot of option are available…

I am in folder view layout but it doesn’t seems to affect the desktop icon that created by a widget. How do I activate the widget with double click. I couldn’t find any option

It only applies to folders, files and shortcuts(links). It doesn’t affect widgets. When I drag and drop an application I can already create links but I don’t like them. There is secon option to create icons under widgets.

Okay. I guess I can’t have the best of both worlds. What annoyes me is when I right click them it treats it as a shortcut not as shortcut to the application