Opera and Vivaldi Not Working Correctly

After installing the updates this morning:

  • Vivaldi won’t open properly and function - opens half screen, max and min don’t work, won’t close

  • Opera won’t copy and paste from the url line

Nothing whatsoever was changed on my system, except installing the updates from Majaro.

No problems here with Vivaldi (on KDE). About Opera I don’t know, I don’t use that.

I use Budgie DE. Could the issue be there?

Maybe, no idea which window-manager Budgie uses (which is community-supported with Manjaro), never used that as well.

How do you use Vivaldi? In a native window? Try unchecking and rechecking that in the Settings and restart the browser. In chrome://settings you could also search for Gtk+ and switch between classic and GTK+ and see if that would also help (restart).

Apart from those maybe a Budgie user can be of help.

I had an issue with vivaldi a few updates back where i had to F11 to full screen then F11 again before i could change the size, but that was on kde.

That’s different, iirc this was related to KDE itself and was affecting other programs as well and was fixed in 5.19 (or it could be also 5.18 …)

1 Like

Is opera in official repo or are both from AUR?
Maybe worth rebuilding them.

Opera is in the community repo, yes. Vivaldi is in AUR and in the very convenient [herecura] repo maintained by the same TU.

After an update - always rebuild packages build from AUR.

It may also be required to restart your system - or if only apps was updated logout and login.


Since my OP I have not taken any remedial action. Yesterday I tried a restart and reboot a couple of time but nothing corrected the issues.

This morning I booted as normal. Vivaldi now opens, closes and minimizes properly. Also copy and paste from right click is working. In Opera, right click copy and paste is still not working.

It may be a Budgie issue. Not surprising :frowning: Budgie Workspaces not working correctly - won’t open a new instance of Vivaldi or Opera in a new Workspace.