Opera 77 - no more hardware video decode?

Just notice there is no more hardware video decode flag in opera://flags.
Did a step-by-step guide how to enable HVA with chromium-flags.conf but… it does not works.

it’s now --enable-features=VaapiVideoDecoder instead of --enable-accelerated-video-decode. See Chromium - ArchWiki

I have those flags:


in file ~/.config/chromium-flags.conf

Still not works.

Did you test with a video that’s at least 720p?

Yes. Still no luck :frowning:

Did you try this?

To reduce CPU usage while watching YouTube where VP8/VP9 hardware decoding is not available use the h264ify or enhanced-h264ify extension.

You can check what your GPU supports running vainfo (part of libva-utils).

Just installed h264ify and it says FFmpegVideoDecoder. CPU usage is high even on 1080p
It definitely not works :stuck_out_tongue:

vainfo output:

vainfo: VA-API version: 1.12 (libva 2.11.1)
vainfo: Driver version: Mesa Gallium driver 21.1.4 for AMD RENOIR (DRM 3.41.0, 5.13.1-3-MANJARO, LLVM 12.0.0)
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            :	VAEntrypointVLD
      VAProfileMPEG2Main              :	VAEntrypointVLD
      VAProfileVC1Simple              :	VAEntrypointVLD
      VAProfileVC1Main                :	VAEntrypointVLD
      VAProfileVC1Advanced            :	VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:	VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:	VAEntrypointEncSlice
      VAProfileH264Main               :	VAEntrypointVLD
      VAProfileH264Main               :	VAEntrypointEncSlice
      VAProfileH264High               :	VAEntrypointVLD
      VAProfileH264High               :	VAEntrypointEncSlice
      VAProfileHEVCMain               :	VAEntrypointVLD
      VAProfileHEVCMain               :	VAEntrypointEncSlice
      VAProfileHEVCMain10             :	VAEntrypointVLD
      VAProfileHEVCMain10             :	VAEntrypointEncSlice
      VAProfileJPEGBaseline           :	VAEntrypointVLD
      VAProfileVP9Profile0            :	VAEntrypointVLD
      VAProfileVP9Profile2            :	VAEntrypointVLD
      VAProfileNone                   :	VAEntrypointVideoProc

Even under opera://flags “Hardware video decode” is not there.

What did you choose to block? Your GPU supports h264 and VP9, so don’t block those.

Right, that flag has been replaced as I mentioned above.

Ok, from what I see, it looks like Opera does not works with chromium-flags.conf
There is no flags switched in opera://flags, everything is default.

Got it working in Vivaldi by changing settings manually

Yes, it does. check chrome://gpu and look at Command Line, you should see the flags you enabled.

EDIT: Apparently something changed. Add the flags to /etc/opera/default instead:


They’re two different things. Some options can only be added to the config file as command line flags.

I think they are not enabled :stuck_out_tongue:

Yeah, just realized that. I edited my post above.

Bingo! :slight_smile:

Right-o. Time to update my guide.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.