OpenVPN 3 failing after system update

Hi all, this is a bug I had after last system update, and I found a solution (temporary) so I’m posting here in case someone else has the same problem.
With latest OpenVPN3 from Aur, after current system updates, when I try to login to the vpn I get the following error:

** ERROR ** Failed calling D-Bus method UserInputProvide: GDBus.Error:net.openvpn.v3.sessions.error: Backend VPN process has died. Session is no longer valid.

This prevents VPN from connecting, and client dies.

I found a (temporary) solution which is to downgrade GLIB to version 2.74 instead of using the current 2.76. To do the downgrade, there’s a tool in the AUR called “downgrade” which can be installed and simply running the following does the downgrade:

sudo downgrade 'glib2=2.74.6'

Be careful, because doing downgrade can break your system. After you downgade, connect to the vpn (which now works) and then upgrade again doing this:

sudo downgrade 'glib2=2.76.1'

This is not a permanent solution, and if you switch networks all the time is very complicated to downgrade/upgrade every time to connect. But its a solution until the devs of OpenVPN find a solution.


PS: If you know a better way of fixing this please let me know!

Did you rebuild openvpn3 after the update? All AUR packages need to be rebuilt when any of their dependencies get updated. It is not an automatic process.

Yes, it’s up to date, and it fails with that error. I also tried uninstall completely and reinstall, and rebuild again and get same error.

You could try openvpn-git which actually compiles the package.

From the linked issue above, it might be the case that they are using functions from the old glib which behave differently now. Then, you’re out of luck and need to wait for them.

Yes, I already tried openvpn-git, but I get same error. It seems I’ll have to wait for the issue to be solved.

Is there a reason you can’t use the stable version of openvpn?

All the OpenVPN 3 packages I tried fail, even stable ones. Glib broke it. If you find one that works, let me know please.

I think they mean the stable version 2 and not the experimental 3.

I can’t use version 2, the server I’m trying to connect requieres configurations only available in v3.

Dear friends,
Any update on this issue? I’m having the same problem with openvpn3 after the last Manjaro update:

openvpn3 session-start --config ~/client.ovpn                                                   ✔ 
Using configuration profile from file: ~/client.ovpn
Session path: /net/openvpn/v3/sessions/18f733c7s4ea5s48d9s9188s6f1687b78a5b
Auth User name: <my-user-name>
Auth Password: 
** ERROR ** Failed calling D-Bus method UserInputProvide: GDBus.Error:net.openvpn.v3.sessions.error: Backend VPN process has died.  Session is no longer valid.

And to me, the downgrade solution didn’t work:

sudo downgrade 'glib2=2.74.6'                                                                           9 ✘  12s  

Downgrading from A.L.A. is disabled on the stable branch. To override this behavior, set DOWNGRADE_FROM_ALA to 1.
See  for more details.

No results found
Unable to downgrade glib2

It’s up to the devs of OpenVPN 3 to fix this.

Issue on github is here:

I got told that it should be fixed for v21 (which is next openvpn3-git package I think) so in the following weeks this hopefully is solved.
EDIT: I just got a systemd update and a couple of other updates and it seems this got fixed. Not really sure which package fixed it for me, but problem is gone.
EDIT 2: After 2 days for some reason problem started again :frowning: . So no idea whats happening, I’ll try to dig more into this.

have you tried with sudo DOWNGRADE_FROM_ALA=1 downgrade ‘glib2=2.74.6’ ?