OpenSnitch blocks Mullvad VPN from working

Looks like that problem exists only here. I’m using Mullvad VPN, GUFW firewall and now installed OpenSnitch but it doesn’t allow for connection. It asks for it, I say YES!, I can see that there is so many connections allowed and ports, still… Mullvad is unable the make one and there is no internet.
When i turn off OpenSnitch, it works. I tried restarting both daemons, did nothing.
I’m using Mullvad-vpn-git from AUR and also OpenSnitch-git from AUR.
Why would it not connect despite of all connections allowed?

Considering OpenSnitch is a firewall (according to GitHub - evilsocket/opensnitch: OpenSnitch is a GNU/Linux port of the Little Snitch application firewall), my first guess would be that it blocks the connections and/or port(s) required by Mullvad.

More than that, I can’t help you.

Opensnitch is no replacement for configuring your firewall

opensnitch should work well with gufw. But by definition, opensnitch only takes care of the outgoing traffic. :footprints:

You have to look what ports Mullvad-vpn-git needs and to enable them in GUFW (for incoming traffic).


I’d rather say he has to check his outgoing ports in OpenSnitch, then.

But :man_shrugging: I’m no expert.


Are you sure?

OpenSnitch is an application firewall. Did you allow Mullvad VPN when prompted?

Yes, it also asks if I want to allow it or deny. That’s how rules are created here. I allow and I see that there are connection happenin’ to Mullvad servers but GUI says no.

Of course, I allow them.

I’m gonna log soon into my system and check that out. Mullvad works well with GUFW alone, doesnt work in combination. I think i tried disabling GUFW and it made no difference but maybe I should restart daemons too.

I think you misunderstood him. @Yochanan is the maintainer of mullvad and you said you’d installed the git version, there’s no git version in the aur

Yeah, I made mistake. It is Mullvad-vpn-bin. When you enter that repository first link is: mullvad-vpn-bin.git
and I was typing from memory.

I think I found what’s wrong. I messed up with GUFW and created custom rules in OpenSnitch, it didn’t help at all. I switched to OpenVPN from Wireguard and it ASKED for OpenVPN connection to allow while for wireguard there is no such prompt. @Yochanan could you tell me what do I have to allow for Mullvad’s wireguard to make it work? Or it’s some kind of universal protocol?

1 Like

That’s a question for a developer, not a packager. I would search the OpenSnitch issues for wireguard. :wink:

1 Like

Oh, okay :upside_down_face: Anyway. I think it’s solved then. Thank you for making Mullvad available for us.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.