Openscad preview wierdly broken

I noticed that openscad no longer shows preview correctly. Problem appears when using difference() function. The part that supposed to be cut off (subtracted) does not subtract in preview. When rendering, everything seems to be ok. Version of openscad is 2021.01-10 and I tried to downgrade it and even tried the newest appimage version 2024 but the same problem appears no matter what version of openscad is in use. The same version works in different computer with intel graphics ok. This makes me think that the problem is related somehow to the graphics on this particular computer. The output of inxi -G:

  Device-1: AMD Navi 21 [Radeon RX 6900 XT] driver: amdgpu v: kernel
  Display: wayland server: v: with: Xwayland v: 23.2.6
    compositor: kwin_wayland driver: X: loaded: amdgpu
    unloaded: modesetting,radeon dri: radeonsi gpu: amdgpu resolution:
    1: 1920x1080 2: 1080x1920
  API: EGL v: 1.5 drivers: radeonsi,swrast
    platforms: wayland,x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.2-manjaro1.1
    renderer: AMD Radeon RX 6900 XT (radeonsi navi21 LLVM 16.0.6 DRM 3.57
  API: Vulkan v: 1.3.279 drivers: radv surfaces: xcb,xlib,wayland

Problem appears as well in X11 and Wayland. I haven’t noticed any problems elsewhere. No any error messages etc. I’m clueless.

Let us know what you find:


It seems that it is a bug (Weird rendering issue with difference() in "F5 Preview" after using "F6 Render" · Issue #4861 · openscad/openscad · GitHub) in the amd mesa v: 24.0.2-manjaro1.1 and it is fixed in a version Mesa-24.0.4. Maybe somewhere in the future the mesa will be updated to the fixed version. Hopefully soon.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.