OpenRGB Always Defaults to Local Server?

I’ve been using openrgb for a while to set my motherboard’s lights to red mode to wind down for the night and avoid blue light.

It worked great for a while, but lately has been booting to the local mode instead of exerting actual control over the RGB lights.

root@MidnightStarSign:/home/sarah# openrgb  
Attempting to connect to local OpenRGB server.
Connection attempt failed
Local OpenRGB server unavailable.
Running standalone.
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
1E 9F 01 01 00 00
78 3C 00 00 00 00
00 00 00 00 00 00
00 00 00 00 00 00
00 00 00 08 09 02
01 F4 00 00 00 00
00 00 00 00 00 00
00 00 00 00 00 00
00 00 00 00 00 00
00 00 00 00 00 00

How can I restore control over the motherboard RGB lights again?

System:
  Host: MidnightStarSign Kernel: 5.10.56-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 11.1.0 Desktop: KDE Plasma 5.22.4 Distro: Manjaro Linux base: Arch Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME X570-PRO v: Rev X.0x 
  serial: <superuser required> UEFI: American Megatrends v: 3001 date: 12/04/2020 
CPU:
  Info: 16-Core model: AMD Ryzen 9 5950X bits: 64 type: MT MCP arch: Zen 3 rev: 0 
  cache: L2: 8 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 217721 
  Speed: 2948 MHz min/max: 2200/3400 MHz boost: enabled Core speeds (MHz): 1: 2948 
  2: 2991 3: 2782 4: 2841 5: 2658 6: 2519 7: 2698 8: 2747 9: 2893 10: 2979 11: 2925 
  12: 3015 13: 2907 14: 2992 15: 3657 16: 2907 17: 2987 18: 2759 19: 2818 20: 3087 
  21: 2714 22: 2627 23: 2694 24: 2880 25: 2608 26: 2637 27: 2925 28: 3686 29: 3017 
  30: 2930 31: 2621 32: 2712 
Graphics:
  Device-1: NVIDIA GA104 [GeForce RTX 3070] vendor: ASUSTeK driver: nvidia 
  v: 470.57.02 bus-ID: 0b:00.0 
  Device-2: Microdia USB 2.0 Camera type: USB driver: snd-usb-audio,uvcvideo 
  bus-ID: 7-1:2 
  Display: x11 server: X.Org 1.20.13 driver: loaded: nvidia resolution: 
  1: 1920x1080~60Hz 2: 1920x1080 3: 1920x1080 
  OpenGL: renderer: NVIDIA GeForce RTX 3070/PCIe/SSE2 v: 4.6.0 NVIDIA 470.57.02 
  direct render: Yes 
Audio:
  Device-1: NVIDIA GA104 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus-ID: 0b:00.1 
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus-ID: 0e:00.4 
  Device-3: JMTek LLC. Plugable USB Audio Device type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-1:2 
  Device-4: Schiit Audio Schiit Modi 3+ type: USB driver: snd-usb-audio 
  bus-ID: 3-2:3 
  Device-5: ASUSTek ASUS AI Noise-Cancelling Mic Adapter type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 5-5:3 
  Device-6: Microdia USB 2.0 Camera type: USB driver: snd-usb-audio,uvcvideo 
  bus-ID: 7-1:2 
  Sound Server-1: ALSA v: k5.10.56-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: no 
  Sound Server-4: PipeWire v: 0.3.33 running: yes 
Network:
  Device-1: Realtek RTL8125 2.5GbE driver: r8169 v: kernel port: d000 
  bus-ID: 05:00.0 
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: 3c:7c:3f:a6:c3:22 
  Device-2: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel 
  port: c000 bus-ID: 07:00.0 
  IF: enp7s0 state: down mac: 24:4b:fe:5b:08:2a 
Bluetooth:
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB 
  driver: btusb v: 0.8 bus-ID: 3-5.3:6 
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends 
Drives:
  Local Storage: total: 4.01 TiB used: 2.12 TiB (52.8%) 
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS100T3X0C-00SJG0 
  size: 931.51 GiB temp: 53.9 C 
  ID-2: /dev/nvme1n1 vendor: Western Digital model: WDS100T2B0C-00PXH0 
  size: 931.51 GiB temp: 47.9 C 
  ID-3: /dev/sda vendor: Seagate model: ST2000LM015-2E8174 size: 1.82 TiB 
  ID-4: /dev/sdb type: USB vendor: Generic model: USB3.0 CRW -SD size: 238.3 GiB 
  ID-5: /dev/sdd type: USB vendor: Samsung model: Flash Drive FIT size: 119.51 GiB 
  ID-6: /dev/sde type: USB vendor: Toshiba model: TransMemory size: 14.92 GiB 
  ID-7: /dev/sdf type: USB vendor: SanDisk model: Gaming Xbox 360 size: 7.48 GiB 
Partition:
  ID-1: / size: 767 GiB used: 641.66 GiB (83.7%) fs: btrfs dev: /dev/dm-0 
  mapped: luks-466d5812-64c7-4a28-bcc4-a1a5adfa9450 
  ID-2: /boot/efi size: 511 MiB used: 26.1 MiB (5.1%) fs: vfat dev: /dev/nvme0n1p1 
  ID-3: /home size: 767 GiB used: 641.66 GiB (83.7%) fs: btrfs dev: /dev/dm-0 
  mapped: luks-466d5812-64c7-4a28-bcc4-a1a5adfa9450 
Swap:
  ID-1: swap-1 type: partition size: 64 GiB used: 0 KiB (0.0%) dev: /dev/dm-1 
  mapped: luks-81b2dc57-06f5-4471-b484-77c3a516f307 
Sensors:
  System Temperatures: cpu: 54.4 C mobo: N/A gpu: nvidia temp: 45 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:
  Processes: 809 Uptime: 7h 53m Memory: 62.78 GiB used: 14.81 GiB (23.6%) 
  Init: systemd Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 2039 Shell: Bash 
  v: 5.1.8 inxi: 3.3.06

That message is normal. It runs in local mode if you aren’t already running an instance with server enabled. It also looks like it’s able to communicate with devices, as the block of hex code printed out is the configuration data from your motherboard. Try running as root and see if that allows control.

:wink:

@Sarah See:

1 Like

Missed that lol. I’m stumped then, as root should have access to the hardware for sure. @Sarah did you try restarting the computer? Try a full complete power off, including shutting off the PSU or unplugging the PC for 60 seconds. The RGB controllers on some motherboards are powered off of the ATX 5V standby power so if the chips lock up, a simple reboot won’t always restart them.

Is it controlling your keyboard?

See:
Adam Honse / OpenRGB · GitLab

Check the username on that GitLab :slight_smile:

2 Likes

Ah, nice to see you here! :wave:

Either way, I posted the link for the OP’s benefit. :wink:

Oh!

That must have been it. The kernel was updated and I forgot to re-enable the kernel module.

I just forgot that I had to do that. I’ll make a flashcard so that doesn’t happen again :smiley:

I’ll give it a try tonight!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.