Openkinect setup


I attempted to install an xbox kinnect camera using cmake and git
The dependencies are:

Python 3.9.4

and I did a:

$ cd libfreenect
$ mkdir build
$ cd build
$ cmake ..

But when I try to load the camera using freenect-glview I get:

Number of devices found: 0

When I run lsusb | grep Xbox, I get:

Bus 001 Device 013: ID 045e:02b0 Microsoft Corp. Xbox NUI Motor


cmake -L

gives me:

CMake Warning:
No source or binary directory provided. Both will be assumed to be the
same as the current working directory, but note that this warning will
become a fatal error in future CMake releases.

CMake Error: The source directory “/home/n0p3/libfreenect/build” does not appear to contain CMakeLists.txt.
Specify --help for usage, or press the help button on the CMake GUI.
– Cache values

If anyone knows how to install it on manjaro it seems to not be happy. libusb is uptodate. My best guess is it is a path issue. Thank you for your time.

fatal error: libusb.h: No such file or directory
30 | #include <libusb.h>

I’m not familiar with the exact package you’re trying to build but if:

it just should work…

So, please, post an inxi --admin --verbosity=7 --filter --no-host --width, as that would be the minimum required information we need to help you… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


1 Like

inxi output

  Kernel: 5.4.114-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID= rw quiet udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel, plank wm: xfwm4 
  vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: Apple product: MacBookPro11,4 v: 1.0 serial: <filter> 
  Chassis: type: 9 v: Mac-06F11 serial: <filter> 
  Mobo: Apple model: Mac-06F11 v: MacBookPro11,4 serial: <filter> 
  UEFI: Apple v: date: 06/11/2020 
  ID-1: BAT0 charge: 83.4 Wh (96.1%) condition: 86.8/99.8 Wh (87.0%) 
  volts: 12.8 min: 11.4 model: DP bq20z451 type: Li-ion serial: N/A 
  status: Full cycles: 365 
  RAM: total: 15.52 GiB used: 2.56 GiB (16.5%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: Intel Core i7-4770HQ bits: 64 type: MT MCP 
  arch: Haswell family: 6 model-id: 46 (70) stepping: 1 microcode: 1C cache: 
  L2: 6 MiB bogomips: 35128 
  Speed: 998 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 998 2: 998 3: 998 
  4: 998 5: 999 6: 998 7: 999 8: 999 
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2 bts 
  clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm 
  dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase 
  fxsr ht ibpb ibrs ida invpcid invpcid_single lahf_lm lm mca mce md_clear mmx 
  monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm 
  pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdtscp rep_good 
  sdbg sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 
  tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xsave 
  xsaveopt xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Crystal Well Integrated Graphics vendor: Apple driver: i915 
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:0d26 class-ID: 0300 
  Display: x11 server: X.Org 1.20.11 driver: loaded: intel 
  unloaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 3840x2880 s-dpi: 96 s-size: 1016x762mm (40.0x30.0") 
  s-diag: 1270mm (50") 
  OpenGL: renderer: Mesa DRI Intel Iris Pro Graphics P5200 (HSW GT3) 
  v: 4.5 Mesa 21.0.3 compat-v: 3.0 direct render: Yes 
  Device-1: Intel Crystal Well HD Audio vendor: Apple driver: snd_hda_intel 
  v: kernel bus-ID: 00:03.0 chip-ID: 8086:0d0c class-ID: 0403 
  Device-2: Intel 8 Series/C220 Series High Definition Audio 
  driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20 
  class-ID: 0403 
  Device-3: Broadcom 720p FaceTime HD Camera driver: N/A bus-ID: 04:00.0 
  chip-ID: 14e4:1570 class-ID: 0480 
  Sound Server-1: ALSA v: k5.4.114-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Device-1: Broadcom BCM43602 802.11ac Wireless LAN SoC vendor: Apple 
  driver: brcmfmac v: kernel port: efa0 bus-ID: 03:00.0 chip-ID: 14e4:43ba 
  class-ID: 0280 
  IF: wlp3s0 state: down mac: <filter> 
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 
  bus-ID: 2-2.3:4 chip-ID: 0bda:8153 class-ID: 0000 serial: <filter> 
  IF: enp0s20u2u3 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Apple Bluetooth Host Controller type: USB 
  driver: btusb,hid-generic,usbhid bus-ID: 1-8:3 chip-ID: 05ac:8290 
  class-ID: fe01 
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 233.76 GiB used: 5.57 GiB (2.4%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Apple model: SSD SM0256G 
  size: 233.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: SA0Q scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 233.46 GiB size: 228.74 GiB (97.98%) used: 5.57 GiB (2.4%) 
  fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A 
  uuid: 27825e3f-109d-4613-9e80-79b25356e422 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 296 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL 
  uuid: B250-361D 
  Alert: No swap data was found. 
  Message: No unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 14 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 1-1:9 info: NEC HighSpeed Hub ports: 3 rev: 2.0 speed: 480 Mb/s 
  power: 100mA chip-ID: 0409:005a class-ID: 0900 
  Device-1: 1-1.2:10 info: Microsoft Xbox NUI Motor type: <vendor specific> 
  driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 045e:02b0 class-ID: 0000 
  Hub-3: 1-5:2 info: VIA Labs USB2.0 Hub ports: 5 rev: 2.1 speed: 480 Mb/s 
  chip-ID: 2109:2817 class-ID: 0900 
  Hub-4: 1-5.4:5 info: Genesys Logic Hub ports: 4 rev: 2.1 speed: 480 Mb/s 
  power: 100mA chip-ID: 05e3:0610 class-ID: 0900 
  Device-1: 1-5.4.2:7 info: Razer USA DeathAdder 2013 type: Mouse,HID,Keyboard 
  driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  power: 100mA chip-ID: 1532:0037 class-ID: 0301 
  Device-2: 1-5.4.4:8 info: Razer USA DeathStalker Expert type: Keyboard,Mouse 
  driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  power: 500mA chip-ID: 1532:0202 class-ID: 0300 
  Device-3: 1-5.5:6 info: VIA Labs USB Billboard Device type: Billboard 
  driver: N/A interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 100mA 
  chip-ID: 2109:8817 class-ID: 1100 serial: <filter> 
  Device-4: 1-8:3 info: Apple Bluetooth Host Controller 
  type: Keyboard,Mouse,Bluetooth driver: btusb,hid-generic,usbhid 
  interfaces: 6 rev: 2.0 speed: 12 Mb/s chip-ID: 05ac:8290 class-ID: fe01 
  Device-5: 1-12:4 info: Apple Apple Internal Keyboard / Trackpad 
  type: HID,Keyboard,Mouse driver: apple,bcm5974,usbhid interfaces: 5 rev: 2.0 
  speed: 12 Mb/s power: 500mA chip-ID: 05ac:0274 class-ID: 0300 
  serial: <filter> 
  Hub-5: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-6: 2-2:2 info: VIA Labs USB3.0 Hub ports: 4 rev: 3.2 speed: 5 Gb/s 
  chip-ID: 2109:0817 class-ID: 0900 
  Device-1: 2-2.3:4 info: Realtek RTL8153 Gigabit Ethernet Adapter 
  type: Network driver: r8152 interfaces: 1 rev: 3.0 speed: 5 Gb/s 
  power: 288mA chip-ID: 0bda:8153 class-ID: 0000 serial: <filter> 
  Hub-7: 2-2.4:5 info: Genesys Logic Hub ports: 4 rev: 3.1 speed: 5 Gb/s 
  chip-ID: 05e3:0612 class-ID: 0900 
  System Temperatures: cpu: 45.5 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 228 Uptime: 2h 55m wakeups: 396 Init: systemd v: 247 
  tool: systemctl Compilers: gcc: 10.2.0 Packages: pacman: 928 lib: 265 
  Shell: Bash v: 5.1.0 running-in: xfce4-terminal inxi: 3.3.04 ```

Also I ran

sudo pacman -U libfreenect-git-v0.6.2.r0.g4d6b941-1-x86_64.pkg.tar.zs

Ah, no driver loaded! :sob:

Have you tried 5.10 LTS, or if that doesn’t give you a driver neither, 5.12 stable yet?

If no driver loaded neither, you indeed need to follow these instructions and if you did, you made a typo:

cmake -L ..

the .. will ensure you build the project one directory level up.

If you would have any errors go here to open issues, but everyone will assume you’re a developer that knows how to program C, C++ and Python.


1 Like


Good to know I can try a different kernel. Spaced on that,
but saw that it actually should grep 3 devices total. 2 cameras,
and a motor. I will definitly go back and RTFM on cmake. I was
under the impression that using the makepkg as an alternate
installation method would work. I will try a scratch install again,
under a different kernel. I am pretty sure I hit all the correct
python packages. :grinning:

Openkinect libfreenect is in the AUR (Arch User Repository) as libfreenect.

1 Like